Calling shared script from Alarm Notification Pipeline


For my first alarm pipeline, I’m trying to only call a script and it doesn’t seem to run. This could probably be done with a tag event script. When the script is called from the Script Console it works fine. I’ve tried both project and shared scripts; neither work. I also tried adding a delay after, still not working. Looks like the pipeline is retiring without running the script.

Does there need to be some sort of roster associated with a simple pipeline as shown below?

Wrapper output and Alarm Configuration below.





INFO   | jvm 2    | 2019/04/12 16:18:37 | I [a.N.Pipeline                  ] [00:18:37]: Alarm pipeline started. project-name=[global], alarm-pipeline=Low
INFO   | jvm 2    | 2019/04/12 16:19:26 | I [a.N.Pipeline                  ] [00:19:26]: Alarm pipeline scheduled to retire. alarm-pipeline=Low, project-name=[global]
INFO   | jvm 2    | 2019/04/12 16:19:26 | I [a.N.Pipeline                  ] [00:19:26]: Alarm pipeline retired

Okay it works when I use the Alarm Active tag event handler and a shared script.

1 Like

Alarm pipelines (in 7.X) are a “global” resource, meaning they don’t have access to project-specific resources (ie, project scripts). You should still have been able to call a shared script, but the project script not working is expected behavior. The way this works is different in 8.0, but still compatible with pipelines and scripts written in 7.x.

We are running 8.1.3, and I can’t access a shared script. Is this still expected behavior? My goal is to have an alarm turn on, delay for 15 minutes, and then run a specific function, wait 15 more minutes, and then run a separate function. Both of the functions I mentioned will be scripts in the project library. I’m receiving errors in the logs about “No module named…” and “global name ‘scriptname’ is not defined”.

I should probably add that the script is in our parent project, which is the same project where the Alarm Pipeline is located.

‘shared script’ is too vague for 8.0+. You said you’ve got a parent project that contains the pipeline - it also contains the script library in question? How are you calling this script, exactly?

Never mind. We just had the wrong Gateway Scripting Project specified. Once I set that to the Parent Project (which is where we keep all of our scripts) everything started working fine.

Thanks for the quick response.

1 Like