Can a view AND it's contents be duplicated?

i'm sure this is a silly question, but when i copy/paste a view to duplicate it, none of the components transfer with it. i'm doing some breakpoints for devices orientation and i'd rather not rebuild the view for every breakpoint. i just wanna shuffle and tweak. :slight_smile:

yes should be possible,
what are you trying to paste where?
show a screen shot with arrow :slight_smile:

shift + right click on a view will add copy json and paste json to the contextual menu. Use them.
That being said, copying and pasting views should work, I do it every day...

1 Like

yeah. i thought this was basic. but every time i right-click the view, and then paste... it just copies the view with none of the components. here's an image of the results (renamed for clarity):

Screenshot 2023-07-05 083005

maybe a reboot? i'll try that.

EDIT: i also tried copying the root and pasting that... but paste is greyed out.

How are you trying to paste it ? Onto another already existing view ?
Also... did you try to, you know... open it ? The things inside the view don't show up in the project browser until it's opened.

the text box obscures it, but there is a folder above. i am trying to paste into that. but i have tried to paste just about anywhere. and, uh... no. there's no triangle to twirl open... so i... well for !@#$ sake... how am i supposed to know that?? :stuck_out_tongue:

once i double click the new view, it populates. is that normal? THAT makes no sense. but whatever. quirk of the software, i guess. :confounded: thank you. i never would have thought to open what appears to be an empty view. :+1:

should we just delete this thread and pretend i never asked this question?? :smiley:

It doesn't populate, it just... opens.
Try closing your views, you'll see they all look just like this.

okay. i see what you're saying. because i only have a couple views, i expected the same UI results NOT REALIZING that ONLY when the view is OPEN in the whatever-middle-area-region do the components populate in the Project Browser. so my expectation was, like any other software, it would show the UI bits, open or not. i shouldn't have to open a view just to see the components; i should just twirl it down and look at the list.

oh well (#3). quirk of the UX. thanks for hashing this out with me.