Can anyone recommend a 48 port rack-mountable NAT Switch/Router?

I have 36 machines. They are all copies of each other as far as the network goes. PLC is always kept at 192.168.0.100. The idea is to run a line to every machine. And do 1:1 Port Aware NAT translation. Plugging into the spare port on PLC comm coprocessor. They’re L18s or whatever so no extra network card. Right?

The server lives at: 120.120.80.212

For example:
Port 1 --> 192.168.0.100:44818 --> 120.120.80.1 <–> Server
Port 2 --> 192.168.0.100:44818 --> 120.120.80.2 <–> Server

I have a couple of these machines already on a cheap(<50$) ubiquity 5 port edge router. Using this strategy and they work really well. Bought me time to integrate them. They, however, don’t have din rail and the have a barrel plug adapter for power. They do make a rack-mountable 12port. I am pretty fond of there simple web UI. These cabinets are full as it is too on the machines. AB’s translator starts at like 800$ for a two-port. There are other device-level switches. But, I want to do this in the server closet. Our 3rd party IT people won’t help. Come to find out today after a heated meeting that they sub-contract their switch programming out. Lol

So does anyone have the hookup for a similar easy to use a network switch with 48 or so ports? Or 4 of the ubiquity edge routers?

Any guidance here is much appreciated!

MikroTik have a few 48 port 1u mounting switches.

Ie used a lot of their kit from routers, switches, access points and 10GB fiber links and had no issues at all.

You’re looking for a 48 port router, which really isn’t a thing. My suggestion is get a 48 port switch, assign each of your machines to their own VLAN, and then use an upstream router to handle all your NAT needs.

Ubiquiti does make some 48 port switches, but I would advise towards more ‘industry ready’ hardware (Cisco, Arista, Aruba, etc.) or use whatever your IT department is comfortable with. If your budget only allows for Ubiquiti then so be it, just know that it may end up being the weak link sometime down the road.

A layer 3 managed switch basically includes some of the functionality of a router within the switch, no?

Some do. I have a Catalyst 3750G Poe-48 From 2006. And it seems that it does not support NAT translation at the port. It’s unclear what this switch is I was told it was a layer 3 switch. It was EOL in 2012 lol. This is what our IT guy gave me.

But, yeah, Ideally I have one box set up for these machines. Not a couple of boxes doing IT things that are going to be difficult for me to set-up and maintain.

This is what I am trying not to do. With the advancement of network switch equipment. It really should be a thing Lol. And that thing should be able to be set up by someone like me. As far as down the road goes all this box will ever do is what I am describing above. Famous last words. I know.

I am hesitant to use the ubiquity, although the edge router I have has been great. Which is why I am asking for a more robust solution. Or run openWRT on something. That might be easier. They are going into a server closet. I have a budget for a nice device. I just need to find the device. If it is actually a thing. Thanks, man!

Good stuff man. Thanks a lot! Do you think the CPU can handle 36 machines with 1000ms scan times? about 25 tags

The total non-blocking throughput is 168 Gbps, switching capacity is 336 Gbps and the forwarding rate reaches 235 Mpps

Yes, but not usually NAT.

If you’ve gotten things working on your test setup I see no reason why you couldn’t do it yourself with a switch/router-on-a-stick setup. It’ll take 1U more space but you’ll gain features like firewall that an L3 switch won’t offer. That being said, I am interested if anyone else can recommend you a product that does what you’re looking for.

1 Like

I really like this guy. I am trying to reach out to someone smarter than I to confirm. Uses routerOS and that is what is on the ubiquity if i recall correctly. 500$ suggested msrp: CRS354-48G-4S+2Q+RM

1 Like

Woah! Freaking awesome Layer 2 stats and features. A bit wimpy for Layer 3, but it does appear to have the NAT functionality are looking for.

2 Likes

For good prices on MikroTik products you can’t beat these guys. Outside the US but I’ve never had any issues and I’ve spend upwards of 10k $ with them.

1 Like

This NAT functionality is CPU intensive. No? How would a guy figure out if it could handle the load I am going to throw at it?

Which is 36 ABs with about 25 tags polling at 1000ms.

Have you looked at the device statistics for a single connection? That’ll give you an idea of the number of requests per second. Figure on the order of 512 bytes each direction per request, times 8bits per byte on the wire. I would expect 25 tags to fit in a single multi-function request, especially if you use a UDT in the PLC to consolidate items. Which suggests that unit has plenty of bandwidth for your needs.

1 Like

Thanks, man! Time and time again you’ve been generous with your time… I got one on the way and will report back.

@craigb Thanks, man!

1 Like

I appreciate the Mikrotek links. A few years ago, layer 3 switching was red-hot, and you had your pick of Juniper, Netgear, Cisco/Linksys/Meraki, Ubiquiti, HP. I tried Mikrotek but their web and command interface was just terrible. Then it all just disappeared and the big players wanted to separate switching and routing again.

Ubiquiti’s still a solid player, and I think they’re impossible to beat if you also need PoE, but I will pick up a new Mikrotek for my next project and see how it performs.

Are you still using the Mikrotek with today’s firmware?

At the risk of a slight thread derail, I just ordered the CRS312-4C+8XG-RM. At $599 list, it’s pretty well priced.

Going in to my office for 10Gb use, and I don’t need any management whatsoever as it’s going in to an already pretty busy rack.

I’ll report back on the modern day firmware setup.

1 Like

Let’s get off the rails Lol. Mine will be here on Thursday. I will put something together as well when I can.

Arrived middle of the week;

Pro’s:

  • Lightweight, easy to get in to my rack which is over 2M tall… much easier than the 3KVA UPS that went up there… Good build quality I don’t imply it feels cheaply built
  • Plugged it in, connected SFP to separate Switch and connected a few 10G connections, didn’t even go in to the console, it just worked

Con’s:

  • Did go in to the management to try and control the fan speed. Whilst it will report the setpoint is 41DegC for fan activation, there is no control, just status. OK for a server server room, but not so good in my day to day office
  • See image, I broke the internet

I go my L3 switch in today. It had a screw not floating around in it. Lol.

I had to take case apart and find it. It was one that holds the pcb to the frame. I made it up. I am glad I shook it like a kid under a Christmas tree first lol.

I am updating firmware currently. I am going to take it home as homework over the weekend. And set it up.

when it comes to mikrotik products, winbox is your friend.

3 Likes

Ports 1 - 42

Translates IP address like:
Port 1: 192.168.1.1 (Private) -> 127.158.79.1 (Public)
Port 42: 192.168.42.1 (Private) -> 127.158.79.42 (Public)

To talk to an ignition server at 127.158.80.1

# jul/05/2020 04:15:11 by RouterOS 6.47
# software id = G5MK-UT30
#
# model = CRS354-48G-4S+2Q+
# serial number = **********
/interface bridge
add admin-mac=C4:AD:34:C2:09:B3 auto-mac=no comment=defconf fast-forward=no name=bridge
/interface ethernet
set [ find default-name=ether48 ] arp=proxy-arp
set [ find default-name=sfp-sfpplus1 ] rx-flow-control=auto tx-flow-control=auto
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/user group
set full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api,romon,dude,tikapp
/interface bridge port
add bridge=bridge comment=defconf interface=ether48 learn=yes
add bridge=bridge comment=defconf interface=ether49
add bridge=bridge comment=defconf interface=qsfpplus1-1
add bridge=bridge comment=defconf interface=qsfpplus1-2
add bridge=bridge comment=defconf interface=qsfpplus1-3
add bridge=bridge comment=defconf interface=qsfpplus1-4
add bridge=bridge comment=defconf interface=qsfpplus2-1
add bridge=bridge comment=defconf interface=qsfpplus2-2
add bridge=bridge comment=defconf interface=qsfpplus2-3
add bridge=bridge comment=defconf interface=qsfpplus2-4
add bridge=bridge comment=defconf hw=no interface=sfp-sfpplus1
add bridge=bridge comment=defconf interface=sfp-sfpplus2
add bridge=bridge comment=defconf interface=sfp-sfpplus3
add bridge=bridge comment=defconf interface=sfp-sfpplus4
add bridge=bridge comment=defconf interface=ether47
add bridge=bridge comment=defconf interface=ether46
add bridge=bridge comment=defconf interface=ether45
add bridge=bridge comment=defconf interface=ether44
add bridge=bridge comment=defconf interface=ether43
/interface list member
add interface=bridge list=LAN
add interface=qsfpplus1-1 list=WAN
/ip address
add address=127.158.80.25/18 interface=sfp-sfpplus1 network=127.158.64.0
add address=127.158.79.11/24 interface=bridge network=127.158.79.0
add address=127.158.79.12/24 interface=bridge network=127.158.79.0
add address=127.158.79.13/18 interface=bridge network=127.158.64.0
add address=127.158.79.14/18 interface=bridge network=127.158.64.0
add address=127.158.79.15/18 interface=bridge network=127.158.64.0
add address=127.158.79.16/18 interface=bridge network=127.158.64.0
add address=127.158.79.17/18 interface=bridge network=127.158.64.0
add address=127.158.79.18/18 interface=bridge network=127.158.64.0
add address=127.158.79.19/18 interface=bridge network=127.158.64.0
add address=127.158.79.20/18 interface=bridge network=127.158.64.0
add address=127.158.79.21/18 interface=bridge network=127.158.64.0
add address=127.158.79.22/18 interface=bridge network=127.158.64.0
add address=127.158.79.23/18 interface=bridge network=127.158.64.0
add address=127.158.79.24/18 interface=bridge network=127.158.64.0
add address=127.158.79.25/18 interface=bridge network=127.158.64.0
add address=127.158.79.26/18 interface=bridge network=127.158.64.0
add address=127.158.79.27/18 interface=bridge network=127.158.64.0
add address=127.158.79.28/18 interface=bridge network=127.158.64.0
add address=127.158.79.29/18 interface=bridge network=127.158.64.0
add address=127.158.79.30/18 interface=bridge network=127.158.64.0
add address=127.158.79.31/18 interface=bridge network=127.158.64.0
add address=127.158.79.32/18 interface=bridge network=127.158.64.0
add address=127.158.79.33/18 interface=bridge network=127.158.64.0
add address=127.158.79.34/18 interface=bridge network=127.158.64.0
add address=127.158.79.35/18 interface=bridge network=127.158.64.0
add address=127.158.79.36/18 interface=bridge network=127.158.64.0
add address=127.158.79.37/18 interface=bridge network=127.158.64.0
add address=127.158.79.38/18 interface=bridge network=127.158.64.0
add address=127.158.79.39/18 interface=bridge network=127.158.64.0
add address=127.158.79.40/18 interface=bridge network=127.158.64.0
add address=127.158.79.41/18 interface=bridge network=127.158.64.0
add address=127.158.79.42/18 interface=bridge network=127.158.64.0
add address=127.158.79.43/18 interface=bridge network=127.158.64.0
add address=127.158.79.44/18 interface=bridge network=127.158.64.0
add address=127.158.79.45/18 interface=bridge network=127.158.64.0
add address=127.158.79.46/18 interface=bridge network=127.158.64.0
add address=127.158.79.47/18 interface=bridge network=127.158.64.0
add address=127.158.79.48/18 interface=bridge network=127.158.64.0
add address=127.158.79.49/18 interface=bridge network=127.158.64.0
add address=127.158.79.50/18 interface=bridge network=127.158.64.0
add address=127.158.79.51/18 interface=bridge network=127.158.64.0
add address=127.158.79.52/18 interface=bridge network=127.158.64.0
add address=127.158.79.53/18 interface=bridge network=127.158.64.0
add address=127.158.79.54/18 interface=bridge network=127.158.64.0
add address=127.158.79.55/18 interface=bridge network=127.158.64.0
add address=127.158.79.56/18 interface=bridge network=127.158.64.0
add address=127.158.79.57/18 interface=bridge network=127.158.64.0
add address=127.158.79.58/18 interface=bridge network=127.158.64.0
add address=127.158.80.24/18 interface=bridge network=127.158.64.0
add address=192.168.1.75/24 interface=ether1 network=192.168.1.0
add address=192.168.2.75/24 interface=ether2 network=192.168.2.0
add address=192.168.3.75/24 interface=ether3 network=192.168.3.0
add address=192.168.4.75/24 interface=ether4 network=192.168.4.0
add address=192.168.5.75/24 interface=ether5 network=192.168.5.0
add address=192.168.6.75/24 interface=ether6 network=192.168.6.0
add address=192.168.7.75/24 interface=ether7 network=192.168.7.0
add address=192.168.8.75/24 interface=ether8 network=192.168.8.0
add address=192.168.9.75/24 interface=ether9 network=192.168.9.0
add address=192.168.10.75/24 interface=ether10 network=192.168.10.0
add address=192.168.11.75/24 interface=ether11 network=192.168.11.0
add address=192.168.12.75/24 interface=ether12 network=192.168.12.0
add address=192.168.13.75/24 interface=ether13 network=192.168.13.0
add address=192.168.14.75/24 interface=ether14 network=192.168.14.0
add address=192.168.15.75/24 interface=ether15 network=192.168.15.0
add address=192.168.16.75/24 interface=ether16 network=192.168.16.0
add address=192.168.17.75/24 interface=ether17 network=192.168.17.0
add address=192.168.18.75/24 interface=ether18 network=192.168.18.0
add address=192.168.19.75/24 interface=ether19 network=192.168.19.0
add address=192.168.20.75/24 interface=ether20 network=192.168.20.0
add address=192.168.21.75/24 interface=ether21 network=192.168.21.0
add address=192.168.22.75/24 interface=ether22 network=192.168.22.0
add address=192.168.23.75/24 interface=ether23 network=192.168.23.0
add address=192.168.24.75/24 interface=ether24 network=192.168.24.0
add address=192.168.25.75/24 interface=ether25 network=192.168.25.0
add address=192.168.26.75/24 interface=ether26 network=192.168.26.0
add address=192.168.27.75/24 interface=ether27 network=192.168.27.0
add address=192.168.28.75/24 interface=ether28 network=192.168.28.0
add address=192.168.29.75/24 interface=ether29 network=192.168.29.0
add address=192.168.30.75/24 interface=ether30 network=192.168.30.0
add address=192.168.31.75/24 interface=ether31 network=192.168.31.0
add address=192.168.32.75/24 interface=ether32 network=192.168.32.0
add address=192.168.33.75/24 interface=ether33 network=192.168.33.0
add address=192.168.34.75/24 interface=ether34 network=192.168.34.0
add address=192.168.35.75/24 interface=ether35 network=192.168.35.0
add address=192.168.36.75/24 interface=ether36 network=192.168.36.0
add address=192.168.37.75/24 interface=ether37 network=192.168.37.0
add address=192.168.38.75/24 interface=ether38 network=192.168.38.0
add address=192.168.39.75/24 interface=ether39 network=192.168.39.0
add address=192.168.40.75/24 interface=ether40 network=192.168.40.0
add address=192.168.41.75/24 interface=ether41 network=192.168.41.0
add address=192.168.42.75/24 interface=ether42 network=192.168.42.0
/ip dhcp-client
add disabled=no interface=bridge
/ip firewall nat
add action=accept chain=srcnat comment="DST NAT BEGIN" disabled=yes
add action=dst-nat chain=dstnat dst-address=127.158.79.11 to-addresses=192.168.1.1
add action=dst-nat chain=dstnat dst-address=127.158.79.12 to-addresses=192.168.2.1
add action=dst-nat chain=dstnat dst-address=127.158.79.13 to-addresses=192.168.3.1
add action=dst-nat chain=dstnat dst-address=127.158.79.14 to-addresses=192.168.4.1
add action=dst-nat chain=dstnat dst-address=127.158.79.15 to-addresses=192.168.5.1
add action=dst-nat chain=dstnat dst-address=127.158.79.16 to-addresses=192.168.6.1
add action=dst-nat chain=dstnat dst-address=127.158.79.17 to-addresses=192.168.7.1
add action=dst-nat chain=dstnat dst-address=127.158.79.18 to-addresses=192.168.8.1
add action=dst-nat chain=dstnat dst-address=127.158.79.19 to-addresses=192.168.9.1
add action=dst-nat chain=dstnat dst-address=127.158.79.20 to-addresses=192.168.10.1
add action=dst-nat chain=dstnat dst-address=127.158.79.21 to-addresses=192.168.11.1
add action=dst-nat chain=dstnat dst-address=127.158.79.22 to-addresses=192.168.12.1
add action=dst-nat chain=dstnat dst-address=127.158.79.23 to-addresses=192.168.13.1
add action=dst-nat chain=dstnat dst-address=127.158.79.24 to-addresses=192.168.14.1
add action=dst-nat chain=dstnat dst-address=127.158.79.25 to-addresses=192.168.15.1
add action=dst-nat chain=dstnat dst-address=127.158.79.26 to-addresses=192.168.16.1
add action=dst-nat chain=dstnat dst-address=127.158.79.27 to-addresses=192.168.17.1
add action=dst-nat chain=dstnat dst-address=127.158.79.28 to-addresses=192.168.18.1
add action=dst-nat chain=dstnat dst-address=127.158.79.29 to-addresses=192.168.19.1
add action=dst-nat chain=dstnat dst-address=127.158.79.30 to-addresses=192.168.20.1
add action=dst-nat chain=dstnat dst-address=127.158.79.31 to-addresses=192.168.21.1
add action=dst-nat chain=dstnat dst-address=127.158.79.32 to-addresses=192.168.22.1
add action=dst-nat chain=dstnat dst-address=127.158.79.33 to-addresses=192.168.23.1
add action=dst-nat chain=dstnat dst-address=127.158.79.34 to-addresses=192.168.24.1
add action=dst-nat chain=dstnat dst-address=127.158.79.35 to-addresses=192.168.25.1
add action=dst-nat chain=dstnat dst-address=127.158.79.36 to-addresses=192.168.26.1
add action=dst-nat chain=dstnat dst-address=127.158.79.37 to-addresses=192.168.27.1
add action=dst-nat chain=dstnat dst-address=127.158.79.38 to-addresses=192.168.28.1
add action=dst-nat chain=dstnat dst-address=127.158.79.39 to-addresses=192.168.29.1
add action=dst-nat chain=dstnat dst-address=127.158.79.40 to-addresses=192.168.30.1
add action=dst-nat chain=dstnat dst-address=127.158.79.41 to-addresses=192.168.31.1
add action=dst-nat chain=dstnat dst-address=127.158.79.42 to-addresses=192.168.32.1
add action=dst-nat chain=dstnat dst-address=127.158.79.43 to-addresses=192.168.33.1
add action=dst-nat chain=dstnat dst-address=127.158.79.44 to-addresses=192.168.34.1
add action=dst-nat chain=dstnat dst-address=127.158.79.45 to-addresses=192.168.35.1
add action=dst-nat chain=dstnat dst-address=127.158.79.46 to-addresses=192.168.36.1
add action=dst-nat chain=dstnat dst-address=127.158.79.47 to-addresses=192.168.37.1
add action=dst-nat chain=dstnat dst-address=127.158.79.48 to-addresses=192.168.38.1
add action=dst-nat chain=dstnat dst-address=127.158.79.49 to-addresses=192.168.39.1
add action=dst-nat chain=dstnat dst-address=127.158.79.50 to-addresses=192.168.40.1
add action=dst-nat chain=dstnat dst-address=127.158.79.51 to-addresses=192.168.41.1
add action=dst-nat chain=dstnat dst-address=127.158.79.52 to-addresses=192.168.42.1
add action=accept chain=srcnat comment="BASIC NAT BEGIN" disabled=yes
add action=masquerade chain=srcnat
/ip route
add distance=1 gateway=127.158.80.1
/system identity
set name="Device Translator"
/system routerboard settings
set boot-os=router-os