Can browse but not read OPC DA tags

I'm new to Ignition, installed Ignition locally on desktop, installed OPC Core Comonents, created connection to OPC DA Server.

I can connect to the OPC DA Server, and I can see and browse the tags.

However, when trying to read tags with the OPC quick client, I get the following error when trying to read a tag:
Read completed. [SPM]SPM/K-001.01/100 Ordnung, 1600 Li/DB/Color
Value: null
Quality: Error_Exception
Timestamp: 27.04.23, 16:14:32 MESZ

In the Ignition logs I find these errors:

I'm running DCOM with different users on remote and local. I read somewhere here on the forum that this may cause the problem.

Can somebody please help me fix it? Thanks in advance.


I have tried connecting to the remote OPC DA Server with OPCExpert (installed locally), and both browsing and updates of tags work as expected.

Ignition runs as SYSTEM, OPCExpert runs as uklein, both locally. Can I change the Ignition config to run as uklein?

Since nobody else has offered an explination, I'll take a wild guess. Perhaps try resetting your trial period?

Thansk for the reply, but the issue is not related to the trial period, which was running when I tested.

Well, if nothing else, at least it bumped your question back to the top of the list.

Walk through this guide and make sure you don't miss anything, or call support and they'll probably end up doing the same thing with you:

1 Like

Somewhere in the Windows service management you should be able to change the user/account that a service runs under.

Changing the user that ignition runs as in the Windows Services worked for me.