Cannot browse connection "Ignition OPC-UA server"

I am running Ignition 7.8.2 on
“Linux CCDebianCF 3.20-4-686-pae #1 SMP Debian 3.2.68-1+deb7u3 i686 GNU/Linux”

Simulator Devices:

OPC UA setting

OPC server connection


Error message:


Is there anything missing during my configuration? I had tried to restart the gateway or OPC-UA module.

Thanks. Hope the image links above work or please refer the attachment.


Under the server settings, the “Endpoint Address” setting should just be the IP address of the machine you’re on. After setting it you’ll need to restart the gateway.

Thanks for the advice. The problem is still there.

OPC-UA > Settings > Server > Endpoint Address > changed to “opc.tcp://

OPC Connections > Servers > created a new name and description, authentication “opcuauser/password”

OPC Connections > Servers > OPC Server Connections > endpoint > Discover OPC-UA Endpoints > “opc.tcp//”, check “opc.tcp//”

OPC-UA module restarted,
Gateway restarted.

It is solved. There is a hidden router somewhere in my machine. The solution is
1.OPC-UA -> Settings -> Server -> Endpoint Address -> (IP address of my machine)
2. OPC Connections -> OPC Server Connections -> endpoint -> Discover OPC-UA Endpoint -> opc.tcp://

Thanks all and Sam Ngeru.