Cannot browse for OPC Servers on remote PC

Thanks for advance if you provide the solution.

when i am trying to click on “CITEC.OPCRemote” , it is giving the message like as follows “Cannot browse for OPC Servers on remote PC”.Please help us what we need to do , since we have done DCOM settings.

Sounds like you’re running into typical DCOM configuration issues.

If the computers are in a workgroup, make sure that the same local userid and password are defined on the workstations. Whether the workstations are in a workgroup or a domain, make sure the OPC server and the OPC client are running with/using the same credentials.

For troubleshooting purposes, try using a generic OPC client (e.g., KEPServer’s Quick Client) to get data from the remote OPC server.

Often times you can browse to a OPC server but you can’t get OPC item data because the OPC Enum service, which is responsible for telling other applications what OPC servers are installed on the computer, typically has no requirement for authentication and therefore will work. However, to connect and query OPC items, you do need to have the proper/matching credentials.

MickyBob’s right, I just wanted to add that by going to Help->Log Viewer you can get more information about the error that is occurring. Usually with DCOM errors, you’ll get a message that doesn’t seem to make sense, but if you scroll down you’ll eventually see something like “E_ACCESS_DENIED” or similar. That message might help in figuring out what’s going on.


So, I took a look at the project that you sent us, and from the error logs it appears that you’re just running into DCOM problems. I would follow the suggestions of MickeyBob, as well as looking at some other DCOM guides. The most permissive settings would be to give “Everyone” and “Anonymous Logon” full Local/Remote access on the Citect machine under all 4 buttons on the COM Properties tab of the DCOM configuration tool.

Also see the posts in the Knowledge Base section of the form concerning DCOM logging, which might be useful to you.

In your other post, you referred to connecting locally/remotely to FactorySQL, which isn’t clear to me. If you have FactorySQL on one machine, and CITECT on the other, you should only connect the FactorySQL frontend to the FactorySQL service. I noticed that you have SQLTags enabled using a DSN database connection, which might be causing some difficulties. We recommend only using SQLTags with native database connections, so I suggest trying that. That box you posted is a message that is shown when the frontend attaches to a service that is in the process of starting. Perhaps SQLTags over ODBC is taking a long time to start.