Cannot coerce value into Dataset

Good afternoon.

In Ignition 8.0.9, when I restart the server I see this error in logs.:

Cannot coerce value '{“columns”:[{“name”:“Fecha_Hora_Ejecucion_Ciclo”,“type”:“java.util.Date”},
{“name”:“Segundos_Duracion_Ciclo”,“type”:“java.lang.Float”}],“rows”:[[“Wed Mar 04 18:03:52 GMT 2020”,0.0]]}’ into type: interface com.inductiveautomation.ignition.common.Dataset

The error is in an instance of this UDT:

Best regards.

Which service are you restarting?
Do you mean the gateway?

Good afternoon.

The “server” (OS), no service.

I have done a series of tests that I explain below. I can conclude that there is a serious problem with the data type “date” in the datasets:

I have created:

  • A tag (data type: dataset) with a string column:


  • A tag (data type: dataset) with a date column:


  • A UDT with a dataset with a date column:


  • And an instance of the UDT:


As you can see in the images, I have inserted a row in the three datasets.

When I restart the server (OS), this happens:

  • For the dataset with a string column, everything is correct:


  • For the dataset with a date column, its rows and columns are deleted (“No Data”):


  • For the dataset that is contained in the UDT instance, an error appears in the logs and the dataset disappears:


I have verified it in two Gateways: Windows 10 and Windows Server 2016. It is important to know that I am in Spain and that the operating systems are configured in language and format Spanish. Maybe that is the origin of the incident.

Best Regards.

I believe this is related to a known bug that’s slated to be fixed pretty soon, but I can’t guarantee that. I would recommend getting in contact with support - they can either confirm it’s the same known issue, or file a new bug ticket for you.

Ok, but it is a serious problem that requires an immediate solution because information is lost when you restart the server.

Thank you.

This would be a reason to contact support directly. The forum is great, but not an official support channel so you may or may not get a solution here.

1 Like

You should be aware that bug fixes don’t happen in hours or even days. They take weeks or sometimes months. If this is code that worked on previous version of Ignition, revert to that version. If this is code that has never worked, you might want to use a work-around (like a string column type) until a bug fix is available. IA doesn’t have a stock of magic wands. (It’d sure be nice, though.)


I didn’t want to say “immediate solution,” I wanted to say that you have to be aware that there is a real bug.

Sorry for the inconvenience.

Good Morning.

Is it possible to know when the bug you are referring to will be corrected, in which version?

Best regards.

The bug I was thinking might be the cause of this is fixed in 8.0.11.

Ok. Thank you.

Good afternoon.

I have upgraded to Ignition 8.0.11 and the issue continues.

There is an easier way to reproduce the issue without restarting the server:

  • Create a Data Type containing a Dataset with a date column and another column of any type.
  • Create an instance of that Data Type and add some rows with data.
  • Export the instance to a “.json” file.
  • Delete the instance.
  • Import the “.json” file.
  • An error will occur.


Best Regards.

Did you get in contact with support?

Yes, and they referred us to this forum entry. But I am not sure that it is the same issue.

Can you post or PM me the ticket number with support? That’s not what should have happened.

Good Morning.
I have sent you a private message.