Cannot Copy Script Text on a Mac

It seems that it is not possible to copy text within a script (this includes script modules, event handlers, and property expressions). This only happens on a Mac. I can copy the components and text inside of labels or component properties. It appears to be anything that requires navigating to another page (event handler, property binding, etc.) will not allow me to copy. I am using Ignition 7.3.2 with Java 1.6.0_29 from Apple Inc. Any help/fix for this would be awesome. When you lose the ability to copy/paste you realize how much you rely on it.


Have you tried both Ctrl+C and Cmd+C to copy? I’ll go try this out on a Mac and see what happens.

Edit: It works with Ctrl+C. I recently started introducing Mac-specific shortcuts in the designer, but they obviously haven’t made it everywhere yet.

Oh that did it. The control+c worked (command+c does not). Got so used to using command+c that I never tried using control+c. Seems a little weird though that you have to use command+c on the designer main page to copy a component and use control+c inside of the script editors. Thanks for the help though. Will make my life so much easier.