Cannot create PoolableConnectionFactory v7.9.2 & SQL Server Express 2019

I am setting up an Ignition Gateway (v7.9.20) and am trying to establish a connection to MS SQL Server 2019 (on the local gateway). I keep receiving a database fault with the following error:
Cannot create PoolableConnectionFactory (The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: “No appropriate protocol (protocol is disabled or cipher suites are inappropriate)”.)
I have followed other suggestions of modifying the java.security file and removing the TLSv1 & TLSv1.1 entries from the jdk.tls.disabledAlgorithms entry. I did this as a Hail Mary because, as I understand it, SQL Server 2019 supports TLSv1.2.

After I reread the post. I think I may have misled the reader to believe that the problem has been solved. It has not. I am still unable to connect to my SQL Server.
Thanks in advance.

What OS version is SQL Server installed on? What version of Java are you using for the Ignition Gateway?

There’s some registry keys at the bottom of this KB article that you could verify are correct: KB3135244 - TLS 1.2 support for Microsoft SQL Server

I’ve installed it on a Windows 10 VM. Java 8u333. I had missed that part of the article but there was no improvement even after entering the new keys to the registry.

Sounds like you have all the right pieces. Unless there’s some configuration you need to do in SQL Server to turn it on I don’t know what else could be going on.

What version of the SQLServer JDBC driver are you using?

sqljdbc4.jar

Hmm, no version in it.

Might be worth ensuring you’re on the latest JDBC driver that supports both Java 8 and SQL Server 2019: Support matrix - JDBC Driver for SQL Server | Microsoft Docs

Looks like maybe 7.4 all the way to the latest.

I updated to mssql-jdbc-7.4.1.jre8.jar and it worked! Thanks so much. I would have never figured that out.

Just facing same issue here…did you have to add the new JDBC in the gateway config (that’s what I’m looking at now)…if you did what did you enter as the class name ?

Take a Gateway backup first. The GWBK is just a zip folder, rename it as such and you can then extract the zip and see the contents, inside will be a JDBC folder which will have your current driver (which you can revert to if things go wrong).

To answer your question, yes, go to the gateway/config/(SQL) Drivers/Edit/Select JAR

I did mine with 7.9.12 and SQL 2016 back in June, since that we have tested with SQL 2019 on 7.9.12 in a different server(s), I used the same driver and didn’t modify the class name, just left it as was