Cannot launch the Designer on Linux using Oracle Java 8

I just installed Java 8 on a client machine but when I tried to launch the Designer it froze with the Open/Create Project dialogue partially drawn. This was with Kubuntu 14.04, Java 1.8.0_40 and Ignition 7.6.7.

I then installed Ignition 7.7.4 on another Kubuntu 14.04 machine. The server seems to be happily using Java 8, but the same thing happens when trying to launch the Designer. On both machines when I reverted to using IcedTea (v1.5 using OpenJDK 1.7.0_75) to launch the Designer it worked fine.

Is this a known problem with Linux and Java 8?

Are you launching via webstart or the native launcher?


Welp… same thing happens for me. Thanks for the heads up.

Works fine when using the native launcher, for what it’s worth.

Yes, the native launcher works here as well.

Looks like it’s a Java bug, possibly the same or related to this:

It turns out we DO have this in our ticketing system as well. There’s no fix coming from us, just waiting on Oracle, who seems to have deemed Java 9 an appropriate target for the fix :confused:

:open_mouth: Oh well, roll on 2016 :slight_smile:

I guess this is why the native launchers were made.

Indeed. I’ve been using nothing but the native launchers for a while now (Gentoo Linux / jdk / kde)