Canny Stuck on Redirect After Login

Im trying to login to Canny to make a feature request. I hit the login button and login and get stuck at this page. Anyone able to help? Tried in two different browsers (Chrome and Firefox), and did Incognito and regular mode. Also tried logging in on another service and from fresh.

Mostly trying to suggest that the Ignition Client Launchers sort to not have the blank server names when sorting. I have several customers who do not like seeing the blank servers due to how many servers they use.

Long-standing problem for anyone using tightly locked-down browsers, which is becoming more and more standard. and have some cross-domain security concern that ties the system up. For me, I get redirected back to as if logged in, but then I'm not logged in on the ideas site.

Extremely frustrating. I used to be able to use a different browser set to low security to work with it, but even that stopped helping several months ago.

Honestly, I don't know why they can't host this on their own forum. I don't see what brings to the table that Discourse can't do.