Can't connect to the Lookout OPC Server

In server explorer, see the “properties” of LookoutOPCServer. Under registry tab, is the CatIDs set or not?
If it’s not registered, run these two commands in “Run”,

  1. regsvr32 “c:\program files\national instruments\shared\logos\lkopc.dll”
  2. “c:\program files\national instruments\shared\logos\lkopc.exe” /regserver"
    the directory for Logos may be different.
    Have a try.

This is the only topic I’ve found relating to the Lookout OPC server (on this forum). I’ve tried everything to get a connection from my Ignition Server to my Lookout OPC server. It seems no matter what I do I can’t even connect to the OPC server via the NI Server Explorer on my Ignition System.
It gives me the error:
“Error Connecting Network Registry: Unable to connect to \???! Make sure that this computer is on the network, has remote administration enabled, and that both computers are running the remote registry service.”
I’ve tried enabling the permissions for DCOM, OPCEnum and opened ports/programs through the firewalls. I’ve done everything I can find online about this type of connection… Can’t seem to get a connection.

In response to the above post, Yes the CatIDs are set. I’ve even gone as far as checking the registry permissions.
Does anyone have anything else they can mention that I may try.

This is the error I’m getting from Ignition just in case this helps:

com.inductiveautomation.ignition.common.opcua.UAException: Could not open secure channel to opc.tcp:// com.inductiveautomation.xopc.client.stack.TCPClientChannel.getEndpoints( com.inductiveautomation.xopc.client.stack.TCPClientChannel.getEndpoints( com.inductiveautomation.xopc.client.sropc.ConnectionUtil.getEndpoint( com.inductiveautomation.xopc.client.sropc.ConnectionManager.connect( com.inductiveautomation.xopc.client.sropc.UAServer.setUp( com.inductiveautomation.xopc.client.sropc.UAServer.access$200( com.inductiveautomation.xopc.client.sropc.UAServer$ com.inductiveautomation.ignition.common.execution.impl.BasicExecutionEngine$ java.util.concurrent.Executors$ Source) java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) Source) java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source) java.util.concurrent.ScheduledThreadPoolExecutor$ Source) java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) java.util.concurrent.ThreadPoolExecutor$ Source) Source)

I’ll also post this on the NI Forum. Thanks.

I’ll also add that the Ignition System is running on Windows 7 and the Lookout OPC server is on Windows XP.

techerdone, you’re trying to connect to what appears to be an OPC-DA server with an OPC-UA connection. You’ll need to install the COM module and create a DA connection instead.

Thanks, Kevin. Nailed it.