Can't disable window scaling?

I’ve watched the training videos since the last time I posted. I have a much better understanding of how windows and navigation works. Still, I ask, isn’t there a way to disable window scaling? I want the way I see it in designer to be exactly how I see it when I run the project. I line up all my controls started at the left side of the window, and no matter what I do, when I run the project everything is shifted over to the right a few inches. I’ve tried setting the window and project to run at the exact resolution of my monitor. I still see the same thing. When I manually resize the project window, the contents of the window get bigger and smaller.

Unless someone would like to offer me reasons why it’s better to allow it to scale than having everything static. I’m all ears. And maybe I need to continue learning so I can control more what the program is going to look like for on the client machines.

You need to set the layout of your components so that they are anchored to the top and to the left.

The layout mode for your components is probably currently set to relative.

Thank you for your reply. Do you think you might be able to give me a hint as to how I would go about doing that?

Sure. In the designer click on a component in a window. Then right click on it to bring up the component menu. Then select “Layout”. Then select “Anchored”, then select the arrow buttons so that it is anchored to the top and to the left.

Once you select the “Anchored” layout it might already be configured to anchor to the top and to the left.

Also you can select a component and then use the CTRL+L keyboard shortcut to bring up the layout window.


Thanks. Someone from tech support called right before I saw your reply. He said the same thing you did. I was thinking there would be one master setting for a window. I didn’t think it would be at the component level.

I think I’m good for now.