Can't Edit or View Project Configuration

I can no longer edit or view project configuration from the Gateway. I have a couple of projects I want to enable and can not. Some time after clicking the ‘edit’ link for a project I get a nearly blank page that that simply say’s “Internal Server Error”. I have also seen this happen when I tried to start a mobile project (never heard back about that one).

One time I was able to get to the Config. page but when I tried to ‘save’ it I got the same “Internal Server Error” There didn’t appear to be any applicable errors in the log file. Help please.

Can you get your logs and post them or email them to support? If you can’t get to the console page to export a logs.bin.gz, you can just go get the wrapper.log file(s) from the installation directory and zip those up.

wrapper.log (476 KB)

Hmm, looks like something might be deadlocked… can you get a thread dump? You can get it from the GCU if the console on the gateway isn’t available.

Also - what version is this? After getting the thread dump you may need to restart Ignition to get things back to functional.

I am facing the same issue, the issue is resolved after restarting the gateway. its Ok on the design computer but an issue on the server in the Plant.

Hi everyone,

We just tracked down an issue with the project management system that would cause things to gradually slow down in the web interface- especially on the homepage (listing projects), and in the project edit section of the gateway config.

It should be fixed in the next 7.6.3 beta, going up today or tomorrow.