Can't open designer

I am having this problem on one system that has the RC and not having the issue on another. I’m not sure what causes this issue but I see that it has been an issue in the past with 7.9 so hopefully someone can point me in the right direction to fixing it.

I tried uninstalling Ignition and re-installing it on the system.

This morning I had updates for several different things (dell update, windows update, firewall update, etc) and I suspect one of them broke it.

Hi @Steve_Laubach,

I had a couple of questions:

  1. When you uninstalled and reinstalled Ignition, are you referring to the Gateway running on the address you are attempting to launch the designer from? or the Designer Launcher itself?
  2. Is that gateway running?
  3. Can you successfully launch a designer from that gateway on another system?
  4. Can you connect to the Gateway Homepage from the computer you are attempting to launch from in a browser?

Im going to ask you to do a couple things to help me figure out whats happening:

  1. Could you try uninstalling and re-installing the Designer Launcher and see if that fixes your issue?
  2. If there are still issues, could you clear out your %USER_HOME%\.ignition folder, add the Gateway to the launcher and attempt to launch again? (Some old settings cache issue might exist)
  3. If this fails, can you upload the designerlauncher.log file that is in %USER_HOME%\.ignition\clientlauncher-data

Thanks,
Jonathan C

  1. All of this is on my work laptop so the gateway is running locally.

  2. The gateway is running and I can open a perspective session to that gateway. I tried running the gateway stop bat and then running the start bat but it didn’t fix it.

  3. Good idea. I don’t have another system available at the moment but I’ll try to find a system to test it. I installed the RC on a VM cast from my old work laptop and it opened up designer fine. That install was a 7.9 to 8 RC upgrade. No problems.

  4. Yes.

Trying your recommended fix steps.

  1. After reinstalling designer launcher the problem was still there.
  2. Next I cleared the cache. problem is still there
  3. I deleted the log file, reinstalled designer launcher and attached the new log file to hopefully avoid sending you down a rabbit trail.designerlauncher.log (1.3 KB)

Matching client IP found. that’s very weird. I talked with our main networking guy and confirmed we don’t have a duplicate IP on the network.

Ok, give me a moment to look into this.

Thanks,
Jonathan C

@Steve_Laubach I was unable to reproduce this locally. Could you do a few things for me?

  1. Set the Launchers log level to debug. This can be found in the Settings section which is in the top right hand corner of the launcher. After doing this, please try to launch the designer again and upload the log file again as you did before.
  2. Also, just to rule a few things out, could run the following command from the Command Prompt:
"C:\Users\slaubach\AppData\Roaming\Inductive Automation\Designer Launcher\jre\bin\java.exe" -classpath C:\Users\slaubach\.ignition\clientlauncher-data\launchclient.jar -Djavaws.sr.gateway.addr.0=http://localhost:8088 -Djavaws.sr.launchts=1554742179717 -Djavaws.sr.main=com.inductiveautomation.ignition.designer.DesignerStartupHook -Djavaws.sr.platform.edition= -Xms64M -Xmx1024M -Djavaws.sr.memory.init=64M -Djavaws.sr.memory.max=1024M -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=false -Djavaws.sr.screen=0 -Djavaws.sr.scope=D com.inductiveautomation.ignition.client.launch.BootstrapSwing

Thanks,
Jonathan C

The cmd prompt blew up which I assume is what you were testing. I’ll pm you the logs because they contain the name of a gateway that isn’t mine and is on the internet.