Can't use Color Datatype in Dataset tag anymore, error: 'Invalid DataType for Dataset.'

Hi, i hope you guys are having a good day!
TL;DR: Can’t use color datatype in a dataset Tag, is this a bug? Should i just use a workaround?

I was storing the vision’s easy chart configuration datasets into a dataset memory tag, it worked fine for arround a year, but during the New Year’s recess my client updated their gateway to version 8.1.13 and now i’m unable to use those tags, the problem seems to be on the “COLOR” column where if i remove it or change it to a string, i don’t get the error anymore, which is:

Error_TypeConversion("class java.awt.Color: Invalid DataType for Dataset.")

If i just copy the dataset from a new easy chart’s configuration into a new dataset tag, it also gives me the same error, i’ve also tried to restore an old backup, but it didn’t help either.

I was using this for a screen where the user can customize the chart and then all the configurations can be saved, so if it’s a bug, or it’s working as intended, is there another better method to do the same thing?
Here’s the full message when i try to run the save script or copy the dataset:


And here’s the screen, with my folder containing some of the mentioned tags:

Thank you for your time!

Hmm. I would think it’s related to the change discussed here java.sql.Timestamp value can't be added to dataset - #6 by Kevin.Herron

But java.awt.Color is explicitly allowed…

1 Like

Ah, java.awt.Color was missed in the original change, caught as a bug, then added back recently.

Sorry about the inconvenience. It should work in the 8.1.15 nightly or you can rollback and wait for 8.1.15 or work around this somehow.

1 Like

Thank you for the quick reply, Kevin, i’m short on time but the workaround should’t take long since it seems that i just have to replace the column before writing and when reading the tag.