Changing from Oracle Java to Zulu Java and now I can't open designer

Hello,

I switched over our client’s ignition edge 7.9 from Oracle Java to Zulu Java and now I cannot open the .JNLP designer files. I have feeling its because ignition doesn’t know that I have switched over yet. I followed the steps layed out in the ignition help but it didn’t work. The image below shows what I updated in the ignition.conf file. I tried the JRE java.exe file and the normal java.exe and neither worked. Under the status screen on my edge gateway it still says 1.8.0_275-b01. From what I read that should read Zulu 1.8.0_… so I don’t think I entered something correct. I have restarted the gateway multiple times. Has anyone run into this issue?

image

For reference this is Ignition Edge 7.9.12 on windows server 2016 and Zulu Java 8

I realized I downloaded the development environment not the runtime environment so I downloaded and installed the runtime envirement but its giving me the same results.

In 7.9 the gateway status page doesn’t show the Java vendor, just the version, so things are probably working as expected there with Azul. The issue you’re running into is Azul Java doesn’t come with Webstart, which is required to run JNLP files. You’ll need to use the Native Client Launcher to run designers and clients.

2 Likes

Thank you James! One problem - I don’t have a home page tab to get the native client launcher. I think I had one at one point but it is missing now. Do you happen to know what parameters show/hide the home tab?

You should be able to get it back in the Gateway Config area – see this page in the docs: https://docs.inductiveautomation.com/display/DOC79/Native+Client+Launchers

Kathy, thanks for the reply! I went there and I only had the welcome page and the native client launcher. Both were enabled but I still didn’t have a home tab.

Here are screenshots of what I am seeing.

I had the java runtime environment path in my ignition.conf file I switched it over to the development file path thinking that I needed the development program to open the designer over the runtime. That did not work.

so there are two different things happening here.

ignition.conf is going to dictate that JRE that the gateway is going to use to launch, not clients or designers.

If you are launching from JNLP you will need to install a 1.8 JRE which supports JNLP. A lot of distributions do not support it, though you can download IcedTea which supports this (Caveat, check with the licensing restrictions to know if it conforms to your use case)

The alternative is to download the Native Client Launcher where we bundle a JRE within it so you don’t need to download one on your client machines.

As far as the home tab not appearing. Is there anything in the logs? what modules do you have installed?

Hey JCoffman here are my modules.

I would prefer just to download the native client launcher with the bundled JRE. I think I saw somewhere that that uses Java 9. Will that interfere if the gateway is on Java 8?

no it wouldn’t interfere, the gateway should be running on java 8. I would check your logs for any errors. maybe a gateway restart would fix that piece? im not really seeing how the NCL option could just be gone in this instance. If a restart doesn’t help I might reach out to our support department to do some more in depth digging into this gateway.

I called in to the support department and Jason Ortega helped me get it fixed. Jcoffman and James you were both right. The fix for accessing my designer was downloading the native client launcher. Jason sent me the link and it worked like a charm.

That being said, while my gateway didn’t show the native client launcher downloads, they were still technically there. Having the link helped me access them. We never figured out the issue with the home tab but I don’t really need it if I have access to the designer.

James, Jcoffman, Kathy and Jason thank you all for your help!

1 Like