Changing Username to connect to Oracle Express DB? Breaks Historical Logging


I have a Ignition Test VM connecting to an Oracle Express Install in same VM. I could get Historian to log data using the “system” user. I created a new user “ignition” using Oracle SQL Developer(kinda like MS SQL Management Studio). I tried to give the new “ignition” user as many privileges as possible. But it only made a few tables, it did not make the SQLT_Data tables. Easy Historical chart did not work with “ignition” user in Database connection.

I could go back and modify the Database connection and use the “system” user again and I could get it to start logging Historical data again.

Does Ignition know if it Made the SQLT_Data tables under one user and won’t try to create them again, even though I am using a different Oracle user name? Or maybe I don’t have the permissions correct on my “ignition” user?

As for Oracle XE Database structure, what I could glean off the internet. You can’t make a new “clean/ empty” database you only get XE. But you can make a new user, then you when connect as your new user you only have access to that user’s tables and you wont see all the System user’s tables. Correct me if I am thinking about this wrong. I am MS SQL where you can create a new

So I played around and modified the Connect URL to embed the user name and password after the “thin:” and before the “@”. Still no luck.
I thought maybe I can create a Historical Transaction group. Sure enough it made the Group_Table and I could drag Tags over.

The weird thing is that it will only update data to the Group_Table after a reboot. I rebooted multiple times and I get new data in the table after each reboot.

I think I will go back to square one. Maybe do a fresh install of Ignition and Oracle Express, test if a created User can be used to do Historical Logging. Also I need to watch when I import my Backup from Production environment, maybe that is breaking something?

Yesterday I rolled back my VM and reinstalled Oracle Express. I made a new database user “ignition” and gave him a good amount of permissions.

This rolled back VM never had a DB connection, so I made a new DB connection and used the 'ignition" user. I turned on historical on some simulator tags and I made a Historical group and all the tables and data logging is operating correctly.

Recap -Do not change the user name/ password of the Oracle Database connection “mid development”, set up your user first and stick with that User

Future test - maybe if I would have deleted the Database Connection vs just modifying the username/ pw maybe it would have created the tables under the new user’s schema?

In my opinion this is most likely Java on the gateway caching the credentials.
I know that when we move an application from pointing at our DEV Oracle servers to PROD we have to clear the Java cache on the gateway machine or the web methods calls will fail due to login issues.

1 Like