Clearing table data on view load

When I open a popup the table flashes up the data that was saved in Designer. The binding then updates and populates the table with the correct data. I want to prevent the Designer data from showing up.

I could clear the table before saving in Designer but would have to remember to do it and there's the associated delay in generating the test data again when revisiting the Designer.
I've tried setting the table's data property to None in the startup event script but that doesn't do the trick.

Any other ideas?

Uncheck 'Persistent' in the table data props? Should be automatically unset when you apply a binding.

It was unset already.

Well, let's start from zero: Look at the saved view.json and make sure the data isn't there.

If I Shift-right-click the view in Project Browser, Copy JSON and paste it into a text editor all the Developer table binding data is there (as I expected).

The binding config, yes. But no stored table data?

Does the table do the same thing if you open the Perspective session in an incognito window?

That's interesting and I hadn't considered trying that.
Thanks for the help. I'll have to follow up tomorrow.

I have the exact same problem describe on first post.
I tried to uncheck persistence setting of data property of table.
Still the session shows the data from designer when it was saved.

On the designer, when I delete the view parameter that is use to query data on table, table is empty, when I save on designer. Initial data will not show up on table which is good.

Is there other way, to not show designer table's data on session at page load? - without deleting data on designer's table.