Client connections to server with multiple NICs

I have a pair of redundant servers with 3 NICs: PLC, HMI and a dedicated network for redundancy (RED), obviously with different classes.

When I start a Vision client (or even the designer), the client tries to use the RED network only, even if I created the link in the launcher using the HMI network, and fails, because the client can only reach the server on the HMI network (I used the tcpview tools by sysinternals to monitor the java.exe connections).

I searched in the gateway settings and I cannot find a way to force the vision application to bind only on the HMI network. Am I missing something?

Some months ago I hadn't any problem, the client only moved the virtual machines of the servers to a different host.

Any idea?

Use a hostname, not IP addresses. Use a DHCP server that knows how to "localize-queries", yielding the correct underlying IP address for the name, based on which network made the name query.

Then put the DNS name in your gateway settings as the public address.

Thanks Phil,
I tried with the IP addresses because I connected to the plant using a VPN, and I couldn't use the hostname.

At the plant, if I ping the Ignition server hostname from a PC in the HMI network, it replies with the IP of the HMI network, correctly.
When I try the Vision client, using the hostname, it tries to connection to both the HMI network and the redundancy network and the client will start in a couple of minutes (I don't know if it waits for the wrong connection to timeout).
If I try to launch the client directly from the Designer, the first time the Vision client starts immediately, from the second time on, the Vision client tries to connect only to the redundancy network and fails to connect due to timeout.

I find this behaviour very strange and I don't know what is happening. I will try something (including your idea) when the plant is not in use, but I will have to wait some weeks.

That is a design error. The redundant gateway needs to be on the exact same networks as the primary gateway. And both primary and redundant gateways need to be set to use their names as their public addresses.

If you are connecting remotely, put entries in your own /etc/hosts file with the appropriate names if you cannot make your local DNS provide them.

(In most cases, there should not be a redundancy network. It can lead to "split brain" situations.)

1 Like