Client Launcher "broke" after upgrading to 7.9.10

Sunday we upgraded to 7.9.10. Today we could not use the 7.9.9 CL to start any projects. The CL displays all of the projects available but when you try to run a project nothing happens. The log file contains these entries:

INFO  [ClientLauncherFrame           ] [17:35:16,696]: Using java executable under C:\Program Files\Java\jre1.8.0_121
INFO  [ClientLauncherFrame           ] [17:35:16,697]: Starting Java with the following parameters:java -classpath C:\Users\cjvr\.ignition\clientlauncher-data\launchclient.jar -Xms512M -Xmx1024M 1024M -Dsun.java2d.d3d=false com.inductiveautomation.ignition.client.launch.BootstrapSwing 
ERROR [ClientLauncherFrame           ] [17:35:21,717]: Java process launch failed with error code 1: Error: Could not find or load main class 1024M

If we upgrade to the 7.9.10 CL it works… unless the OS is a 32 bit version of windows. I believe it is trying to use the 64-bit version of Java. Webstart works so we can run our clients but the clients on the production floor use the CL to start automatically and this is not working.

hi @CJVR

This issue was fixed in the 7.9.10 Native Client Launchers. You can use the ones with a bundled 64-bit runtime or the legacy versions which are stored on the gateway under lib/core/launch/. The other workaround is to add some JVM argument to that project on the gateway.

The legacy launcher worked. Thanks. We are also having problems with Raspberry PIs (using ARM processors). Do you think the legacy linux launcher will work in that case?

@CJVR yes they should. These launchers include fixes for the NCLs but do not include a JRE so make sure that your PIs have a JRE installed. We are hoping to handle this a bit more gracefully in 7.9.11.

I have upgraded to 7.9.10 and the client launcher does not work. I don’t understand why not when the .jnlp uses the same gateway and works just fine. Can someone explain why that is? Seems to me if it was a firewall issue it would block both. Has to be something on the server because I get the same error whether I try from the server desktop or my PC, which is on a completely different network.


Looking at the issue the OP had, is this on a 32-bit client?

Did you update the launcher to the one from 7.9.10? That’s the first one to package its own JRE, and you should use it.

I’m using the 7.9.10 version of the client launcher. What I’ve discovered is that it only works if I add port 8088. If I try to use port 443 I get an error saying the launcher can’t connect. I’ve tried every form of the URL i can think of; with https, without https, with :443, without :443, doesn’t matter. However the .jnlp file has the same URL and it launches the client just fine. Why is that? Yes, the firewall is open for port 443.

I think there was a weird syntax in 7.9 versions when using the launchers with SSL enabled, something like specifying gateway:8088:443 as the address with both ports?

Or maybe that was earlier versions… worth a try.

Yep in 79 especially if Gateway isn’t auto found I do IP:8088:8043