Client won't launch

Ignition 7.9.3
JRE 1.8.0_121

My client for one project won’t start up. I launched it from the ignition gateway web server, but all it does is launch the Java splash and then it disappears with nothing happening afterwards: no j2plauncher.exe process, no files downloaded into the .ignition cache folder, no desktop icon created, nothing. I turned on the java console but it never shows. Can launch client on other machines. Tried updating client PC java to latest (1.8.0_141) without change.

Strangely, there’s another project running on the gateway that I can launch…

Not sure how to diagnose and fix the issue. Any help would be great!


Open the JNLP file in a text editor and see what the memory settings are, make sure you have enough free and that it’s <= 1.5GB if you’re running 32-bit Java.

Thanks Kevin.
I just checked these and initial was set at 512MB and max at 2048MB.
I found the issue.
When I installed JRE on the client I ran into an error, followed a link which presented another offline download link. Installed it and didn’t think about whether it was for the 32 or 64 bit installer. Turns out it was for the 32 bit installer… I’ve uninstalled it and installed the 64bit version and all is working now.


1 Like