CompactLogix

Hello,
I’m a student and I’ve having trouble in understanding how I can connect IGNITION to a device. I need to work with an Allen Bradley PLC through [color=#4000BF]1768-ENBT[/color] module. I’ve read that you have a driver for CompactLogix and I don’t know if this could work for me. In that case, how I set and connect it to my PLC?
I’ve always worked with Intouch and DDE connection, so I don’t know if it is necessary to set up the RSLinx and other OPC server or just RSLinx.
Please, I know this question is too basic but I’m trying a new solution for the labs on my school and I really like to achieve in this with Ignition. Could somebody help me?

Oh a 1768-enbt, must be a L4x model eh?

You do not need RsLinx for Ignition to talk to the CompactLogix no.

You will need the OPC-UA module for ignition.(You can request a free key for just this part, or run the whole system in trial mode)

Basically, you need to know the IP address currently assigned to the PLC.
The system Ignition is running on needs to be able to talk to this IP address(You can verify this by entering the IP address into a web browser, this will take you to an overview page for the 1768-enbt if it works).
Log onto the config for ignition, head to the OPC-UA - Device section.
Add a device, Choose Allen-Bradley, Ethernet, CompactLogix, hit next.
Give this a name in ‘Device Name’ and put the IP address of the PLC into the ‘hostname’ box. Leave everything else alone for now. Hit save.
You can now go to the Status Page, look at Device Connections, You should see your device connected if everything was successful.

That’s it!

Thank you for your answer, but I was not able to connect with the PLC.

The status of the IGNITION OPC-UA Server was “Connected” but when I tried to “browse OPC Servers” in order to get the tags, no device was found, I don’t know if this has something to do with the fact that “OPC Connections” always stayed under the status of “Connecting” and never changed to “Connected”? As you can see I’m lost and also I have doubts about the “Connection Path” that it’s requested when I configure the device and the correct format to establish the “item path” for the tags if the OPC doesn’t get them by itself.

Could you help me again? Sorry for bothering you.

Describe your ControlLogix architecture and I can help with what the connection path should be? Please include slot numbers and model type of the communications and processor models.

Tom

[quote=“nr352”]I don’t know if this has something to do with the fact that “OPC Connections” always stayed under the status of “Connecting” and never changed to “Connected”?

Could you help me again? Sorry for bothering you.[/quote]

If you refreshed and it never went connected then yes, it’s also a problem. Did you make any changes to the connection configuration? What version if Ignition are you using?

Sorry,

The configuration I’m using is in the attached file. Hope you could help me