Concurrent Requests

Something strange I noted yesterday. I was connected to one of my CompactLogix PLCs via RSLogix 5000 so I could watch incoming data. At the same time I had just started a new historical transaction group on Ignition to log this data using a trigger with the OPC data mode set to read. I tried triggering the data log numerous times with no success. I also noted I was missing one tag due to my oversight so I went to my OPC tag list to get it only to find it wasn’t there. Since this tag had only recently been added to the PLC I figured I just needed to refresh the OPC browser - that didn’t work. So, I tried “refresh browse” on the devices page plus refreshing the OPC browser - that didn’t work. Since I had a connection established to the PLC I thought that might be interfering, so I edited my device connection and set “concurrent requests” to 2 - that worked.

So, my question is, “Did setting concurrent request to 2 have this impact or was it the fact that the device was restarted by editing it?”

The device was restarted by editing it. Hitting save on the device edit page, whether or not you actually made changes, will restart the driver.

Also, we fixed a couple of bugs that were effecting the ControlLogix and CompactLogix drivers ability to detect program changes and mode changes on the PLC and react appropriately. This has been fixed in the 7.2.4 betas that are available in the development downloads area.