Configure Kepware in Ignition

I’m having some difficulty configuring Kepware Server EX V5.6 in Ignition. I have tried both OPC UA and OPC DA device types. I probably have some setting incorrectly set. Any suggestions?

Here is the error message I get from the OPC Connections page. COM object method returns error code: 0x80040154; REGDB_E_CLASSNOTREG (Class not registered)


That error, from the OPC-COM module, indicates that Kepware or the OPC Core Components aren’t installed properly.

You could try re-installing, or getting the OPC Core Redistributable from

However, in general we recommend going with the UA connection. Is there any particular error you’re getting on that front?



I have it working now (I’m not sure what was going on), but I can’t see any data points in the OPC Browser, although I can see the device in the drop down area. Is it possible that I don’t have it configured correctly?


Have you configured your tags in Kepware? Nothing will show up in the browser that you haven’t added to that device.

The driver now shows that it is disconnected and I’m getting a warning.

BasicExecutionEngine Tried to unregister non existant unit [tcplistener:bacnettimeoutchecker]

I’m attaching the console log file just in case you need it.

logs.bin.gz (553 KB)


I did add the tags to the Kepware device and that’s when I noticed the driver was disconnected.


Wait wait wait. Why are you connecting to Kepware and also configuring a driver?


Where should I configure the Kepware server in Ignition? OPC Connections or OPC-UA


In OPC Connections.

It looks like you have configured a TCP driver in the OPC-UA > Devices area; that should be removed.

Focus on the connection to Kepware, which from your logs, does not look to be successfully connected. Feel free to call into tech support if you need some help getting it set up.