Connecting to a NET ENI

Trying to connect to a PLC over a NET ENI. Will not connect. Can ping device.

Have tried disabling browse. Have tried restarting device to free up connections.

Know that nobody likes NET ENIs. I don’t either but it’s what I have to deal with.

Looking for advice.

Using version 7.6.2.

Can you connect to the PLC with RsLinx through the ENI?

What PLC are you connecting to? Have you tried restarting the NET-ENI?

I’ve had a lot of trouble with these too as we have several in our plants. Rebooting usually restored communications, but only for awhile. Currently we only use Digi One IAP if we have intend to go online for programming/troubleshooting purposes. You may have tried this, but try connecting locally via ethernet if possible so you are connecting directly from your pc to the device. Rule out any other networking issues or OPC servers trying to connect such as Kepware. Shutdown RSLinx completely and restart. Also, if that doesn’t work, try restarting the PC you are using to connect with. I feel your pain…

ENIWs are a pain. I found the easiest way to connect to a plc using ENIWs is to setup a read and write message to a PLC with an onboard Ethernet port like a micrologix 1100, 1400 or better yet a compact or control logix. Use the PLC that you are messaging too push / pull the data from your ignition project to the PLC with the ENIW. For some reason message instructions seem to be the only thing ENIWs do well.

Also every driver in linxs that points to the ENIW consumes a connection. ENIW’s are limited to two bidirectional connections, two outgoing connections and two incoming connections.

The ENI and ENIW support a maximum of 6 connections, allowing
simultaneous communication with up to 6 other devices or
applications. The connections are dedicated as follows:
Number of Connections Dedicated to:
2 outgoing messages
2 incoming messages
2 either incoming or outgoing messages

You haven’t yet provided much information beyond your ability to ping, so I’ll give some general ENI advice.

Upgrade to the latest firmware, especially with a series D. Upgrading the D’s I have to 3.22 made a world of difference to me. Also, even if you aren’t using external power for the ENI via the terminal strip, ensure that the ground lug is grounded.

These two things have reduced my ENI troubles drastically.


Finally figured it out.

The PLC was in master slave mode.