Connecting to Ignition's OPC UA server

I am not having any luck with this. I cannot get Unified Automation UaExpert to find the Ignition server. My endpoint address is 192.168.2.134, it is set to allow anonymous access, I added the cert from UaExpert to Ignition, I added the cert from Ignition to UaExpert, I input username and password, I can not find any combination that will allow UaExper to see Ignition. All I ever get is:

“Could not connect to server: BadCommunicationError”
or
"Discovery FindServers on opc.tcp://192.168.2.134:4096 failed (BadCommunicationError)

Is there not any documentation for setting this up? UaExperts instructions just say to add throw in the endpoint and connect.

1 Like

What version of Ignition are you using? Is the Endpoint Address setting for the Ignition OPC UA server set to “192.168.2.134”? Can you ping 192.168.2.134 from the computer you’re running UaExpert on?

Windows 64bit 8.0.2 Ignition currently on a trial license.

Endpoint is currently set to “192.168.2.134”.

192.168.2.134 is/was the computers ip. The client and Ignition are on the same PC.

I assume that since I am only using 1 PC localhost in my OPC client and the default in Ignition should be sufficient?

I have a linux laptop with the same version of trial Ignition on it that I can test with as well. I will see about doing that this evening if I have time.

If this is a new install of Ignition 8 the default port is set to 62541 and the server is configured to bind to localhost only. Can you show me a screenshot of your OPC UA server settings page?

Also, try using this as your endpoint URL: opc.tcp://localhost:62541/discovery. Make sure you have the latest version of UaExpert.

That did it. Adding the ‘/discovery’ allowed UaExpert with it’s ‘Customer Discovery’ function to find it. I’m pretty sure I’ve tried the resulting server properties before manually but I must have had something wrong.

In addition to the discovery I put in the username (opcuauser) and password (password) and moved my UaExper certificate from quarantined to trusted in Ignition gateway.

Despite allowing anonymous access in the gateway, I still have to supply credentials or I get a ‘BadIdentity TokenInvalid’ error in UaExpert.

For posterity here is my OPC server config screen:

1 Like

You have to restart before allowing anonymous starts working.

The server is configured by default to only allow secure connections, which is why you had to append “/discovery” (it runs a separate unsecured endpoint for discovery only).

If you included “None” in the Security Policies list it would have been able to connect to the endpoint URL without “/discovery” as well.

Hi Kevin,

What do you mean “server is configured to bind to localhost only.” ?
Does it mean the endpoint URL can be “opc.tcp://localhost:62541/discovery” instead of “opc.tcp://192.168.2.134:62541/discovery” ?
Thanks.

It means in the default configuration only clients on the same machine can connect.

Thanks for your clarification.

Hi Kevin,

We’ve configured the OPC UA server to accept connections from other machines and this is working for a not-encrypted not signed connection with UA Expert as client. However, we would like to use a signed & encrypted connection. But I received an error during connecting. Below a screenshot of the logviewer on the gateway.

I cannot find a description in the manual on this specific item… Could you help me out?
Gateway info:
2019-09-27%2009_33_56-CoreCertificationTest%20-%20Ignition%20Gateway

In Configuration > OPC UA > Security on the Ignition Gateway go to the Server tab and you should see the UaExpert client certificate in a quarantine area waiting to be marked trusted.

When the authentication setting is changed to ‘anonymous’ mode server goes to faulted mode

Please post configuration settings to connect UAExpert with ignition UA server.

There are no configuration changes necessary if you are connecting from UaExpert on the same machine. You just need to make sure to put in the username/password, opcuauser / password by default.

It sounds like you edited the connection to Ignition’s built in OPC UA server, not the settings for the OPC UA server itself. If you want to enable anonymous access it’s under OPC UA > Server Settings. See https://docs.inductiveautomation.com/display/DOC80/OPC+UA+Server+Settings

Hi everybody.
I try to ccnnect to Ignition OPC-UA server using Matlab OPC toolbox.
I have tried many ways but it doesn’t work :frowning:

this is my matlab code :point_down:

and this is the error i faced :point_down:

I really appreciate if anybody can help me to find out the problem and solve it :pray: :hibiscus: