Connecting to non-supportet Siemens devices?

Hi,

Is it possible to connect to Siemens devices that are not currently supported in Ignition (other devices than S7-300/400/1200/1500)?

I’m specifically interested in the Siemens S5-series and the IM151-8 PLC.

Thanks

Yes, by using another OPC server product that does support it and then making an OPC connection from Ignition to the server.

@Kevin.Herron
Ok, thanks.

Does anybody have any practical experience with this?
Any good suggestions for OPC-Server selection?

Thanks

Kepware has a Siemens S5 driver for their server.

Hi again,

I’ve been told that the IM151-8 is just a S7-300 PLC in new clothes.

What would happen if I connect to it by using the ‘Create new Device’ and chosing ‘Siemens S7-300’?
Have anyone tried it?

Thanks

Worth a shot. If the driver connects successfully that would be the first good sign.

Once connected, as with any other Siemens device, there will be no tags to browse. You’ll have to manually address a test tag you know exists in the PLC.

Hi, for others who might be intersted in this topic:

I succesfully managed to connect to a Siemens ET200S (IM151-8) with Ignition with the device set up as a S7-300.

I only tested with 1 integer in a global data block. I made the int count 1 up every second and reset to 0 at 1000. This was monitorable in Ignition. I also tried to write to the integer from Ignition which worked.

So it seems to work. I don’t know what else I should test to make sure it works as it should.

Thanks

Did you have to change the CPU slot or anything else? I’ve got a similar processor on my bench that I’d like to connect to if possible.

Inductive Automation: Is there an ETA on driver support for these nifty little Siemens PLCs?

Hi Simon, no I didn’t change anything from the default configuration. Just added as a s7-300 in the Ignition devices and entered the PLC’s IP.

Esn,

Thanks for your response. I cannot seem to get it to work. Is there any chance you could compress and provide a copy of your project and the PLC program as an example?

This is a trivial task and I’m a bit frustrated I can’t get it to work for me, I must be missing some very obvious simple step.

Cheers

Hi Simon,
I’m on vacation at the moment, but I’ll reply as soon as I can. Could you tell me exactly what the problem is? Can’t you connect to the device at all or can’t you read tags or something else?

Are you sure your processor is not a newer ET200SP? The ET200S is a S7-300, the ET200SP is a S7-1500. You can use the standard Ignition driver for both, but the 1500 requires a different configuration.

AH HUH!

Nice catch, I believe it is an ET200SP, this could well be my issue. Unfortunately I’m about 7 weeks away from being back in the office to check.

Thank you both for the responses, I’ll have to look into this issue in more detail when I return from this customer site engagement. I’ll update the thread when I get a chance to get it up and running

Thanks again

1 Like

Hi, I’m just trying to get a connection going on a Siemens ET200SP and having issues but your post suggested it possible. I have a valid device connection but can’t get any tags to happily connect to the datablock tags. I’ve used Ignition to get data quite happily from Siemens S7-1500 CPUs, but the same process doesn’t seem to be working on the ET200SP. Do you happen to know if any different settings required or anything on the PLC side for this CPU style? Any thoughts/ideas appreciated! Thanks.

Not as far as my experience goes. The 1510SP and 1512SP cpu’s have the same connection mechanism and settings as all other 15xx cpu’s. So Put/Get access has to enabled, security disabled and there is no access to symbolic adresses, optimized datablocks or legacy timers.

1 Like

Chi, thanks for the response. Now that I know it can work I’ll keep plugging away at it. I’m sure I made all the typical S7-1500 config settings that you mentioned, even updating the firmware to the latest and greatest. It just odd that the device shows as connected in Ignition but I just can’t get tags to connect. Only other thing I’ve thought to check is the TSAP numbers are set correctly - you ever have to mess with that? The ET200SP is in the default rack 0 slot 1 position so I’m thinking should be fine with the default OPC driver settings. Thanks again.

Make sure the DB is global and you disabled optimized access. I didn’t see it in the screenshots you sent into support.

For S7 15xx the driver settings are “Rack Number” =0, “CPU Slot Number” =0 or 1 (both works for me). The default slot=2 will not work.
I made a quick test with a CPU1512SP and can read a global datablock (with optimized access disabled) without problems.

FYI, I got it working. The ET200SP had firmware v1.8 that turns out doesn’t support OPC. I updated to v2.1 and all good. Thanks again for the feedback.

So you are using the built-in OPC-UA server instead of the Ignition driver now?