Connecting Ubuntu install of ignition to AB ControlLogix

I for some reason cannot get my ignition gateway to communicate with my PLC. I can ping the PLC from the same machine the ignition gateway is on. Im running Ubuntu 22.04 and the newest version of ignition. Please help.
Ignition-DESKTOP-LC1OG5I_Ignition_logs_20230907-1346.idb (640 KB)

What Firmware version is on the Controller.
What Device Driver are you using in Ignition to establish the connection.
Is there any routing type device between the gateway and the PLC?
Is the Gateway Address set in the PLC.

If you want/need immediate assistance you should reach out to support.

1 Like

Firmware V32, Im using the control logix driver and have the ip set up as I had it set in windows. I am currently using a project that worked perfectly fine in windows 10 and 11. There is an ethernet switch between the PLC and PC.

Just want to make sure you are using this driver?

1 Like

Sorry, yes I am using the logix driver for v21+

I can't get your logs to load/open.
I would just verify that the IP and slot number are correct.
Also make sure you don't have an IP conflict on either the PLC or the computer that could be making it look like you can ping the PLC, but instead another device is responding possibly.

1 Like

IP and slot number are correct, there is nothing else on the network. I have a similar linux machine going with a micrologix 1400 and it is doing the same thing. I can ping it from the terminal but I can't see it in ignition.

You should collect a packet capture from the Ignition gateway filtered for that target IP. Use something like this:

# tshark -w "Some_PLC_$(date +%Y%m%d_%H%M).pcapng" -i eth0 -a duration:60 'tcp && host'

That will collect a minute of traffic to/from that target IP. Replace Some_PLC, eth0, and with your local values.

Attach the result here for us to review.

Where would I enter this? I'm using Ignition Edge and I haven't seen the command prompt in the gateway.

That would be at a linux command prompt (with root privileges, depending on how tshark is installed). The same kind of command prompt used to install Ignition itself.

(You may need to use your distro's package manager to install tshark--it is part of the wireshark open-source project.)

1 Like

Running that command with root privileges is not working, it starts but when it goes to create the file I am getting a permission denied. Im struggling to find a solution for that.

Ok, this isn't exactly what you wanted, but I think it might work. It captured 39 packets and I did see a rockwell packet.
results.txt (13.7 KB)

No, not helpful. Please use the full tshark command that I recommended, verbatim other than the three substitutions, so that we get just the relevant traffic, and it is saved with all details in a PCAP file.

1 Like

The tshark command you recommended is not working. I cannot get it to output a file, it for some reason does not have permission yet I am running everything as root.

Does your box have its filesystem mounted read-only? Switch directories to some part of the system that is mounted read-write.

The filesystem is read/write as far as I am aware. I also tried having it create the file on the desktop, which I know is read/write and the terminal should have permission to access it even without root.

Even on a flash drive I do not have permission to create the file with root.

What's the full command and output you are seeing when you try what Phil suggested?

Your previous tshark invocation claimed to be writing to a file in /tmp so it must be writable...

efc@EFC-1:~$ sudo tshark -w "/media/efc/0A6F-970D/rf$(date +%Y%m%d_%H%M).pcapng" -i enp3s0 -a duration:60 'tcp && host'
Running as user "root" and group "root". This could be dangerous.
Capturing on 'enp3s0'
tshark: The file to which the capture would be saved ("/media/efc/0A6F-970D/rf20230908_0859.pcapng") could not be opened: Permission denied.

efc@EFC-1:~$ sudo tshark -i enp3s0 -a duration:60 'tcp && host'Running as user "root" and group "root". This could be dangerous.
Capturing on 'enp3s0'
** (tshark:3747592) 09:00:50.557775 [Main MESSAGE] -- Capture started.
** (tshark:3747592) 09:00:50.557935 [Main MESSAGE] -- File: "/tmp/wireshark_enp3s092UNA2.pcapng"
0 packets captured

The first command is what Phil suggested, the second command didnt save a file, but 0 packets were seen.

So, Ignition isn't even trying to connect to that IP address. Have you exceed your Edge license's number of allowed device connections? (The default is just two devices.)

{BTW. Addresses in the 169.254. range are Link Local addresses, and are rarely stable for long-term reliable use. Put proper IP addresses on your hardware.}

That PLC is the only device thats supposed to be connected to the gateway. I am using ignition in a bit of a roundabout way of having the client and gateway on the same machine as this network is going to be fully disconnected from the internet. One device, one client, one gateway. That's it.