Connecting with Siemens S7-1200

I am trying to setup an Ignition 7.6.3 project to save data from a Siemens S7-1200 PLC. In the setup webpage it says connected, and if I browse the PLC in Designer, the Connection State tag always says “Connected”.

However, none of my tags are giving me data. I have configured tags with these addresses:

and the values listed are null in the tag browser and Bad Quality or N/A in the Group Items.

A screen shot of my DB is attached.

We also checked this link and think everything is correct on the PLC side:

What am I missing?


At first glance everything looks ok… have you tried just addressing one tag to see if you can get that working?

Other than that the only guess I have is that your offsets are wrong. You need to have the absolute offset into the datablock, not the relative offset into whatever structure you’re looking at. This is a problem I’ve seen before.

I am not sure if I understand what you are talking about. Do you want me to delete all the tags I have created and have only one?

I don’t know what absolute versus relative addressing means here - the 1200 uses Siemens Portal software instead of Step 7 and it is tag based. And, the screen shot is the entire contents of the DB. However, it does have M registers, so for grins, I tried this but got the same N/A & null responses:

One of the working OPC server tags looks like this:
[9637_PLC]_Meta:[Diagnostics]/Device Name


Maybe just disable (not delete) all the tags you’ve created for that device except one (or at least for that Datablock?), say… [9637_PLC]DB100,REAL258

It might help if you went to the Console > Logs tab on the gateway, clicked the export link, then attached the logs.bin.gz here or sent them into the support email.

Are you able to read other tags from this device? Ones outside this datablock?

The only tags that work are the ones that you get under Diagnostics. That is why I copied one in above in case the syntax I am using is wrong.

Log attached, but I don’t see anything in it. Ignore anything before this morning because I just configured the OPC today.

Any other ideas?

I think you’re going to need to call into support and let them troubleshoot with you. Turning the loggers for the driver to debug and/or trace will be the place to start… there was nothing helpful in the logs you uploaded.

After letting Greg look at it for a while, I decided to try a physical address:
and it gave a value instead of null. After that, I started re-entering all the tags in my DB (listed above) and they all worked. We are guessing that this caused the PLC to actually start polling the tags and returning values.