Connection to local machine SQL DB

Hey guys, I wanted to create a local MS SQL DB on my machine, I’m also running the gateway on my machine but when I try to connect the DB on the gateway it keeps faulting… I don’t get it… I tried both Express and Evaluate version, I didn’t change anything. I followed the step by step and still having Issues. one question thought, when the DB is on the same device as the gateway you use localHost as your device name or can you also use the PC name?
jdbc:sqlserver://localhost\SQLEXPRESS with sa user name and password did not work also
jdbc:sqlserver://ComputerName\SQLEXPRESS did not work either.

Can you log in to the SQL server on that account on a different client application (f.e. SQL server management studio)?

By default, SQL server limits login via regular accounts (but allows login via Active Directory). So you may need to add a different user and give him the correct rights. So make sure you try to connect with the same credentials (no windows login).

The URLs both seem fine.

I’m connected to the SQL Server fine. I went ahead and created a new DB name so I can use it instead of “test” DB.

so my server name is “ComputerName\SQLEXPRESS” and my instance name is “SQLEXPRESS”
does that change anything as far as the address?

And how are you connected to the DB?

Below, you see a screenshot of I being connected to my local SQL server with two different authentication methods. The first connection is done over AD (using my domain account), the second is done with a generic username “atree” and password.

Can you confirm that your connection looks like the second one, and the username mentioned is the one you use in Ignition too?

Can you access the database you want with that login?

Make sure all protocols are enabled for SQL Express.
Follow this guide and it should get it set for you.

I enabled TCP/IP and Named Pipes and restarted the SQL server but still nothing…

Got it. SQL server browser was disabled in the services. enabled it and set it to automatic and connection was made.