Control logix tags don't show up properly

The following causes a problem.

Add a tag to Ignition V. 7.6.3 where the tag does not exist in a Contrologix plc.
Upon adding the tag to the plc, Ignition will still not find it.
If you browse for the tag in Ignition, it will be listed as a directory with nothing in it rather than a tag.
I’ve only noticed this on DINT data types, but it may be others as well.

Upon shutting down the server and restarting, the tags will appear and upon browsing the tags in the plc, the tag will have moved from the directories to the tags and can be selected. This has been a problem in previous versions of Ignition as well.

I experienced something similar to this a few months ago.

Although I think the tag had already been added to the CLX but when trying to read it in Ignition the behaviour was as you described.

A restart sorted it, but obviously that’s not ideal (fortunately we were in the early stages of commissioning a project).

Is this still a problem in 7.6.6 / 7.5.11?

Still there with the Compactlogix V19 & V20.

I just upgraded to V7.6.6 and problem is still there. Due to the large PLC tag count >25K tags per PLC , I have AutoBrowse tags disabled in the connections for each of 4 PLCs in the Gateway . This project is in development and the browse tags after a PLC edit causes issues.

After a new complex UDT tag is added in PLC, I refresh browse . Sometimes, not all, the complex UDT tag appears as a set of folders.

I just toggle between disable the PLC connection and enable , and tag appears OK.

So, in the general terms, what happens is

  1. a new tag is added to the PLC program
  2. the program gets downloaded to the PLC
  3. you refresh the OPC Browser tree in the Designer and try to drill down to the new tag but all you get is an empty folder instead of the tag
  4. This can be fixed by disabling / re-enabling the device connection, or by restarting Ignition.

Curlyandshemp, you are observing the behavior on 7.6.6 with CompactLogix v19 and v20;
jdana have you had a chance to upgrade? What is the firmware version on your ControlLogix?
george What version of Ignition are you running? What is the firmware version on your CLX?

When this behavior is observed, what mode does the device connection show? (After you download the new program with the new tag(s) to the PLC, does the device connection go back to Run mode, or does it get stuck in the Program mode? )

Could you replicate the issue with the device logger on TRACE and upload / email us the log?

1 Like


I’m not going to be able to provide you with much useful info I’m afraid, apart from to say it was ControlLogix v20.

The Ignition version at the time I think was 7.6.3 but it’s now on 7.6.6. I can’t reliably say whether any such issues have occurred since as we typically haven’t been doing PLC and Ignition changes exactly at the same time.

Having just upgraded to 7.6.6 I was slightly concerned reading this thread
as at the moment Auto Browse is still on.

george, sorry it has been a while - I have posted a response in the thread you pointed to.

This remains an issue with Ignition v7.7.1 and Logix v20.x.

Steps to replicate:

  1. Create a sqlTag in Ignition that references a UDT tag that doesn’t exist in the PLC yet.
  2. Create the UDT-based tag in the PLC.
  3. Ignition will get no data, with a config error.
  4. If you browse the OPC source, the the tag’s members appear as folders and cannot be selected.
  5. Cycling the PLC from run to program and back to run has no effect.
  6. Disabling and re-enabling the device in the OPC-UA config has no effect.
  7. Restarting the gateway fixes it.


I am not set up to verify this behavior, but I have put in an internal ticket for this, and will let you know what we find.

Having same issue.

Controllogix 5572 v 20

Ignition 7.8
Test on PC (not production)

Make new tags offline or move tags (change controller to program vice versa), download go to OPC browse, tags appear as they were in previous program, claim “good” status despite tag not existing as mapped

Have tried editing device to wrong IP, saving, changing to correct and saving again…This used to help some (7.7) but now doesnt.

Will try resetting Ignition