Corrupted image library

This was reported by others in the Design Help area…I am basically reposting here.
7.1.1.b5078, possibly after upgrading to 7.1.1, the built-in images library became corrupt.

Most images show just the broken symbol. Agitators (the first folder) appear sprinkled through several of the NEXT few folders.

It looks like an index was corrupted or something.

Not sure whats going on here, we’ll have to investigate.

I reinstalled the same version (7.1.1 b5078) on my development machine, and got the same problem again. I tried it on a fresh, blank Windows XP virtual machine, and it worked. This leads me to believe that it is something on my machine that’s interfering. The list of junk I have on this poor computer is too long to list here, but some of the bigger ones are:

Rockwell RSLogix 5/500/5000 / Emulate 5/500/5000
Siemens Simatic Step7 / WinCC
Wonderware InTouch 9.5
MS Visual C# / C++ Express
GE Cimplicity

Does anyone else with the same problem have any of those? I also have Java 6 update 3, Java 6 update 7, and Java 6 update 17 (odd…), along with J2SE Runtime Environment 5.0 Update 12.

I normally love to blame things on Rockwell :slight_smile: but my machine is clean- only Windows 7 and Ignition.

Well, I got mine to work for a few minutes… I completely uninstalled and reinstalled Ignition and created a new project, and the library was intact. However, once I restored my old project, the image library was corrupted and has stayed that way even when I create another new project. I had manually killed two processes from Sophos Antivirus before reinstalling - maybe that’s it? My project is a very simple one-screen connected to RSLinx and RSEmulate 5000… maybe it brought over a corrupt image library through the projects. I suppose if Sophos wrecked it the first time, it might be propagating through the backup…

Yeah, the images are included in the backup, so if they’ve been corrupted, you’ll get your corrupted images back after doing a restore. The good news is that you can re-build your image library without doing a full re-install:

  1. Open the Designer, go to the Image Management tool, and delete the Builtin folder.
  2. Shut down the Ignition Gateway
  3. Download this file:
  4. Create a folder called “imgimport” in your [tt]%IGNITION_INSTALL_DIR%/contexts/main/db[/tt] folder.
  5. Extract the archive to the imgimport folder.
  6. Start up the Ignition Gateway

This will re-import a fresh copy of the image library.

Worked great. Thanks Carl

We’ve replicated how this problem can be made to happen. It is actually quite serious - it can corrupt project resources as well as images. Needless to say, we’re working on a fix…

Hi Carl - I did follow your earlier instructions and was able to repair the image library (apparently). Is there some other corruption I should be on the lookout for?

If I was to hazard a guess … custom palletes?

Indeed good guess. Nothing visible…I just thought maybe they would have something more insidious for me to look for!

Ok the problem occurs on fresh installs or upgrades of 7.1.0 or 7.1.1 for all images and project resources that are created before you shut down the server for the 1st time.

If you need to do a fresh install, shut down the Gateway and restart it before you start making design changes. If you’re upgrading from pre 7.1.0, do the upgrade and then restart the Gateway before working on it. 7.1.2 will have this problem fixed.

It would be obvious if you had it. Project resources (windows, groups, project properties, etc) are affected.

Good to know. Thanks for the prompt attention!

I think I’m having this or a similar problem, I now have 7.9.8 installed on mac OSX. This computer did have a much older version of ignition on it at one point, I don’t recall which version, probably 5+ years ago. I can’t get any images to work, they all show up with the little red x on top of a page icon. This is consistent in the designer, Image Browser, runtime. All the builtin images and any that I try to import.
I tried to follow Carl’s fix above but can’t find the folder path he references, I assume the %IGNITION_INSTALL_DIR% should be replaced with /usr/local/ignition/ on a standard Mac install.

Thanks for any help.