CPU usage showing "-100%" for gateway

When I access my Ignition gateway, the CPU usage shows -100%. I’ve tried rebooting the gateway and it didn’t fix the problem.

I’m running Ignition version 8.1.14

Which page is it exactly? Can you add a screenshot?

Anything weird to note like running in a VM? What OS and CPU?

It’s the Performance page in the gateway status section. Currently running the gateway from my laptop running Windows 10 Enterprise with an Intel i7-11850H CPU.

I noticed the same problem with 2 recently installed gateways. One of them is full Ignition running on desktop (i7-10700K, Win 10 Pro, clean, first-time install), the other one is Edge version running on my laptop (i7-7700HQ, Win 10 Home, multiple version were installed before), both running v8.1.15 in Trial Mode. The value of system tag “CPU Usage” is also -1.

We get our CPU load from the JVM… Tracing through some of the code on the JVM metrics side of things, I think we’re seeing this bug (where there is a code path that returns -1, which we then multiply by 100 to get the CPU load in normal situations):


I haven’t dug deeper yet as to discover the specifics on how this is manifesting though…

Cross-posting this here too:


This one worked for me.