Custom Perspective session properties not exported

As the subject say, if the project is imported in another designer that does not have them, it becomes unusable.

Did your export contain the session props, and they weren’t imported? Or did you just export the views? What does ‘unusable’ mean - you’re not able to open the view to edit it and fix configuration at all? Are there any error messages shown, or visible in the designer’s logs?

  • On a project with custom perspective session properties, choose file -> export
  • make sure all checkboxes are checked (they usually are) and click “export”
  • save the resulting zip file
  • on a designer on another machine, create and open a new empty project
  • file -> import and choose the previously created zip file
  • make sure all checkboxes are checked (again, they usually are)
  • click “import”
  • the custom perspective session properties that were in the original project are now missing

The imported project is unusable because all components bound to the custom properties cannot bind, all the scripts that reference those properties produce exceptions, etc.

Might be related (If they can’t be saved, they probably can’t be exported):

I ran into another issue today which I’m assuming trickles back to the session properties not saving:
I have (non session) custom properties on some components that disappear when restarting the designer (the custom properties disappear, not the components). These custom properties have bindings to queries and when I attempt to use a session.custom value as a parameter that’s when I run into the issue.
Interestingly enough, when I re-add the custom property to the component, the bindings all automatically reappear. Additionally, everything works as fine from a client session.

This is still present in 8.0.1 rc2. Quite inconvenient if one has lots of custom session variables (as we do).

I think that this might be the same underlying issue as reported here, and if so, was fixed in 8.0.2

I am running into this exact same issue with custom session properties. Exactly as you described. I have not yet restarted the gateway. I’ll try that next.

I am on the most recent version 8.1.10

Bindings have changed quite a bit since 8.0.2, so I would not expect your issue to be the same as was reported here. I suspect what you are encountering (since you claim it’s the same as the original user, and they claim they had bindings in place) is that your properties are not “persistent”. This means that they are not displayed in the property editor until they are resolved (and because of how the property editor renders properties, you would need to click away from the component and then back onto the component).

So assuming that your properties do indeed have bindings in the original project, right-click one of the custom properties with which you are encountering an issue, and in the context menu, set the “Persistent” checkbox to have an enabled/True state. Save the project, and then export again. See if that property is now present.

You could also examine the view.json of the View in question as it is before any changes, and within the propConfig area of the View’s json I would expect to see an entry for each of the properties you are concerned about. As long as the propConfig for the property exists, you’ll be able to see it in the Designer once the property evaluates.