Data Acquisition

Hello,

Is it possible that a frequency acquisition is less than 1Hz?
I wanted to display this table below with more time intervals between seconds.

Thanks in advance!

image

Change the formatting on the column to display the milliseconds.

Actually I needed the sample size to be an interval of 250ms between records on the table

You will probably have to adjust the timestamp formatting to include milliseconds. The next thing to check is to make sure that your datasource has the ability to capture and save at that rate. If you had data at 4 samples/second, I would expect to see 4 records with the same timestamp as formatted above.

1 Like

These images below are my current configuration of the table, sorry if that is a stupid question, but I don’t know how to make the sample size smaller than 1 second (as it just has 3 options: sec, min, hours). I know the datasource can capture and save at that rate, but I don’t know how to display it at the table.

Thanks

image

image

You will have to first create an historical scan class set to 250ms
Then set whatever trend tags you want that resolution at to use that scan class.
Then you right click the table, go to Customize and set the format for the timestamp column to include the milliseconds.
From the screenshots it looks like you have the historical scan class set to 1 second currently.

Actually, the scan class was already set to 250ms

image

Then right click the table, customize, change the column format to include the milliseconds.
Also change your query settings to Sample Size - Natural

2 Likes

1 Like

It is now at 250ms rate! Thanks! But the value are constantly going to a bad quality value. Does that mean that the rate of my datasource is higher than 250ms?

image

But they aren’t displaying milliseconds – you used a lower case ‘s’, which gets you the seconds again.

Yep, your PLC driver is having trouble with that pace.

3 Likes