Data Types with OPC item Path with parameters NOT working

I don’t know why this isn’t working. I used the OPC browser to make a data types by dragging it from the OPC browser to the Data Types folder. But doing this makes all of the tags in the data type OPC Item Path the same as the Tags that you dragged from the browser. So you have to change the Item Path using parameters in the item path, so you can point to different when you make instances of the data type. this worked really well in 7.9 however in 8.0 when I try to do this it doesn’t work or I’m doing something wrong with something that new with 8.0.

This is what the OPC item path looks like with the instances of the data type

This is what it looks like when I edited it.


What I’m doing wrong? Please help.

Did this happen after a conversion from 7.9 to 8.0?

I also had similar problems with my UDTs when importing from 7.9 into 8.0. The fix was to delete the parameter reference in the UDT definition, apply the change, and then paste the same parameter reference back in.

See the existing topic, it may help with your problem:

1 Like

So I made a 7.9 and 8.0 gateway. I think I found out whats going on. I export a data type from the same OPC tag in both 7.9 and 8.0. Before I export I edit a OPC path of one of the tag in the data type. I opened the export files in Notepad++ to edit them. I found out that 8.0 has an extra bit of code the “bindType” in each tag on the data type.

This is 7.9 tag.The OPCItemPath is just the sting that I edited.

This is 8.0 tag.The OPCItemPath is the sting that I edited. With the “bindType”.

This is 8.0 tag.The OPCItemPath is just the sting. Without the “bindType”, because I did NOT edit the path before I export.

In 7.9 is you have a lot of tag in a data type. You can easily edit them by find and replace the part of the OPC path that you need to change, However in 8.0 you can NOT easily edit them by find and replace, because of the missing “bindType”

Is there an easy to fix this? Because the export, edit then import is a easy way to change a lot of tags quickly.

Thanks for the help.

Hi Mark,
I tried the the fix that you said with the export edit then import that I’m have a problem with and it didn’t work. I added to my post with a reply below.
Thank for your help.