Databse Connection Issue

I am having problem to pull up data from the database, at the same time when I run the projects on vision which use the same database, it is pooling up the data from the database but when I go to Datatbase query browser could not see anything for that database even could not able to see anything at DB Browse screen.

Please note that database is saying connected and valid.

Rest of the databases are working fine.

Please find attached screenshots.

Thanks in advance



What database software are you using and version number?

The Hydroform database in that screenshot has 19/16 Connections. Does the connection count ever decrease below the maximum? Do the tables load then?

When count decrease to 8, I tried to load database but negative.

it is DB2/400

Are you seeing errors popup after leaving the Database Query Browser open? What does the “Details” tab of that error say.

And how many tables do you estimate are in the database?

GatewayException: Read timed out
caused by SocketTimeoutException: Read timed out

Ignition v8.1.3 (b2021030309)
Java: Azul Systems, Inc. 11.0.9

Number of table, not sure how many and that was the sole purpose to figure out how many tables are there and what else is stored.

I am able to generate the report which is basically from the same database.

Thanks

caused by SocketTimeoutException: Read timed out

Sounds like the Database connection could be timing out because it can’t list all of its tables within 60 seconds. You should try to connect to the Database using a non-Ignition GUI/console tool to get an estimate of how many tables it might be trying to list.

There is a setting (“Table List Filter”) within the Database Translator in Ignition that allows you to filter the tables listed here, so filtering out things like the system tables could help. You said this issue doesn’t happen for other databases, so you could look at the tables for the “MES_CMS” database (which is using the same driver/translator) connection to confirm if it is listing unexpected tables that could be filtered.

Kvane,

I just noticed that I am having the same problem on MES_CMS database, which is using the same driver.

My most recent response still applies.

The Ignition setting that may impact this is the Table List Filter. If the database has a lot of system tables, or other tables that shouldn’t be listed for the user/schema you are targeting, then you can try to filter them out with that translator setting. That setting is located on the Gateway webpage > Config > Databases > Drivers

Try to load either database in a different GUI tool or client to know more about what tables the database is trying to list.

1 Like

Thanks Kvane,

Open that database on MS Query, yes it has numbers of table and could not able to load in 60 Seconds.

Thanks again for the quick response.