Default is not default

I just upgraded my gateway from 7.2.9 to 7.4.3

A number of projects were using the Default authentication profile. After the upgrade, they all got a error about the a missing default profile.

I had to change the Default profile to default. Then I had to change all the projects that used the Default profile to use the default profile. :frowning:

This sounds very odd. Why did you “have” to change the capital “D” to a lowercase “d”? Do you have a 7.2 backup sitting around that you could try and replicate this on to see if it happens again?

I have the auto backup. I think it was just before the update.
Can I get a ticket number to upload it to? (it’s 20M)

Ticket number is 7239

Ticket number is invalid or …

I think I waiting to long. Can we try a different/renewed one?

I just reactivated that ticket, you should be able to attach to it now. Again, that is ticket 7239.

My file has been successfully uploaded


Well, I’m looking at your Gateway but I’m not sure what I should be looking at.

You have an authentication profile called “default”. Some of your projects are referencing “default” - these are fine. Some are referencing “Default”: these are broken. Perhaps authentication profile lookup was case insensitive in 7.2, and you’d typed them in inconsistently…

Wrong backup then. That was after I changed everything from “Default”

I really should take a backup before I mess with things.

Like I said, everything was “Default” then I upgraded and everything looked good until you tried to open a project. Then you would get an error about being unable to find the “default” profile even though the project referenced the “Default” profile which did exist.

is “default” hard coded somewhere?

Its not hard coded but there is a “default” profile when Ignition is installed

Just tried to recreate this on my dev box.

Upgrading from 7.4 to 7.5 and it all worked fine. Everything was “default”. I changed it to “Default” and then upgraded.

Problem is back on our Demo system.

I have a backup I can upload.

Upload it to the same tag number, 7239


System is running 7.4.3(b995)

I also upload the login details in a separate file.

Ok, we did get it, thank you

Have you found anything?

I am thoroughly confused by this thread. What exactly should we be looking for or … at?

the backup I sent had a “Default” authentication profile defined. The demo project was configured to use it.

When I tried to login, I would get an error that said unable to find “default” profile.

The salient point here here is the capital D vs the lowercase d.

(I may have the case inverted, I forget)

When you went in and changed the name to the profile did everything start working ok?