Default table styles changed, can't find a way to fix it

In the screenshot you can see there is no padding (0px is set) for the content of table cells. But I haven’t made a style like this, and this is the default layout of the table.

How can I fix this?

The padding that was there previously was placed erroneously; it enforced that 5px of padding whether users wanted it or not. If you would like to put the padding in place yourself, you should set the props.cells.style.padding value.

Screen Shot 2021-06-22 at 6.10.46 PM

The 0px padding exists immediately on every insert of a new table component.

This seems like a bug, as I haven’t edited the table properties yet.

Are there default props somewhere in Ignition that can affect this?

The css selector is right above it. .table-container .t ...

If you dont want to change it in every table like @cmallonee suggested, then you could change it with css in a theme using that selector with a new padding.

If you dont have the theme module and dont want to get it just for this you can also ‘inject’ it in a styleclass like i showed here:

something like this should work on all tables:

}.table-container .t .tc .content {
    padding: 5px;
}{

note that doing this will remove the option of changing padding on individual level on other tables

Victordcq, Thank you for your suggestion, but I am saying the default table in my instance is different than what it used to be. Before (as of last week) there was no 0px padding on the default table. (ie, I made no alterations to it)

Edit: If it is relevant, I just updated to 8.1 from 8.0

This was probably changed in an update yes
Because as @cmallonee mentioned doing it like this removes the posibilty to change the padding on one instance of a table

I hope not, it’s a really bad change. Note the padding in the default table here:
https://docs.inductiveautomation.com/display/DOC80/Perspective+-+Table

image

And here is a table I just inserted from the components panel. I have not made changes to it at all.

image

What do your tables look like when you first drag them onto the working area?

As the second one yes

So this was a system change? At least I have an explanation, thank you! I was going crazy!

I can understand the reasons to remove the padding, but the issue is its not consistent. If you are going to remove it from the cells, you should have also removed it from the header cells. By default, the header and the cell content do not align by default which is more my issue that you defaulting to no padding IMO.

image

Yes, because now my headers and cells do not match up.

But I think this was an error, not intentional, and I hope they fix this.

My suggestions return it how it was before, if you need a fix for it right now

I don’t need a fix right now.

I think the goal for components needs to be “looks good enough by default”, and having a 0px padding does not look as good as having their previous default value.