Delete column from pie chart

I’m using a Pie chart, which should read 2 historical tags. And in your dataset I’m using TagHistory to get the 2 tags.

The problem is that when the application goes to runtime, it also takes the column “_tstamp” and overlays the other values.
If I cancel the dataset, it returns again when the application is started again.


Is there a way to cancel this _tstamp column, or some property not to show in the graph?


Move your history binding to a custom property of type dataset.
Change the data property’s binding to an expression binding, and use the columnRearrange function (ignore the name) to filter out the t_stamp column.

Hi PGriffith , thanks for your attemption!
This part worked, but now it takes 4 readings and the first row, in column A, appears blank, I tried some scripts in the graphics to delete just that row, rowindex 0, but it deletes everything, or it deletes the others and this one stays. Do you have any idea? Thanks again

We’ll need to see your scripts in order to see if you missed something in there.

Hi , sorry for the delay…

I did like this:
1o. ( Custom Properties - like said @PGriffith )

2o ( where do i get the values from the table)

3o ( original DataSet)

4o ( to delete the first row)

Hi how are you? Any idea for this step above? Thank you!!

  1. I don’t believe you need to import system here.
  2. Your variable, myList is actually a dataset. I would be careful with the naming.
  3. and event.source.parent.getComponent('PieChart3').data are references to the same property. I would use
  4. A dataset does not have a selectedIndex. I would expect the script to fail here.
  5. system.dataset.deleteRow() takes an Integer argument for the rowIndex, you have supplied it with a List. It "might" be smart enough to do a conversion, but I wouldn’t count on it.
  6. Your configureChart extension function is writing to the Data property, but you also have a binding on that property. So any changes you made in the configureChart function I would expect get overwritten by the binding.

You don’t need the script. You only need the bindings as @PGriffith suggested.

The tag history binding on the Dataset2 custom property, and the expression binding on the Data property.

If you do that and you’re still missing one data point, then I would make sure that nothing else is writing to the data property.

Hi , you are right! I deleted the scripts , and did just the 2nd dataSet like told PGriffith. But I must change something, see below . Thanks for help.

I don’t think you have followed @PGriffith’s advice closely enough. This looks as though you have a Tag History Binding on the Data property of the PieChart.

  1. Create a custom property of type dataset. It can be on the Pie Chart or the Root Container, doesn’t really matter.
  2. Add a Tag History Binding to the custom property with whatever settings you want.
  3. Add an expression binding to the Data property of the Pie Chart using the columnRearrange expression function to filter out the t_stamp column, and populate the Pie Chart.

Yes, that’s exactly what I did. and in the TAgHistory property of the DAtaset2 I configured it according to the printscreen and in the original Data of the Chart I used the ColumnRearrange,tks