Delete records older then - Transaction Group

Hi All,

I have a Transaction Group set as follow:
-Execution Scheduling: “Timer ( 450 ms )”
-Update Mode: “OPC to DB”
-Data Source: “MyDatabase”
-Table Name: “MyTable”
-Automatically create table: TRUE
-Use custom index column: FALSE
-Store Timestamp to: TRUE (“DateAndTime”)
-Store quality code to: FALSE
-Delete records older than: 60 minutes
-Table Action: Insert New Row

This transaction group is not deleting records older than 60 minutes. I have left this Transaction Group “alone” for a week and when I came up today, it had more than 11 million rows…
I know I can easily create a script for deleting records, but why is this option not working? Am I missing something?

Could be a bug, could be a permissions issue. Is there anything in the log?

Nothing inside the logs.
I’ve checked the database permission and I can delete stuff :slight_smile:
Do you suggest to make a script for “delete records older than…”?

Only as a last resort, I suggest contacting support first.

Ok, I’ll do that.
In the meantime I’ll go with the script.

Thanks for the support :slight_smile: