Demo install, connection rejected


MacOS 10.9.3 core i5 16Gig 2.6GHz [below for System Properties out of Ignition Gateway]

Demo, time remaining on this launch is ~20min

About every 10 sec, I get:

10:33:40 AM | OpcUaConnection:Ignition OPC-UA Server | Error connecting to server: StatusCode[Severity=Bad, Subcode=Bad_ConnectionRejected]

There are three demo PLCs (one each of Dairy, Generic, SLC). All three show “Connected” and enabled “true”.

I am trying to access the tags in Designer, and getting an empty tree after clicking the refresh arrow, approximating:

– * Ignition OPC-UA Server

The output console has nothing after “Starting tag polling” (i’d copy/paste the actual line, but copy fills the buffer with a bunch of xml and not the actual line… :scratch:

Suggestions? Is this a MacOS firewall thing?


System Properties
Context State Running
Redundancy Mode Independent
Redundancy State Active
Version 7.6.6 (b2014040112)
Java Version Apple Inc. 1.6.0_65
CPU % 9.5
Memory (used/max) 370 mb / 1,016 mb
Uptime 38 minutes, 56 seconds
Timezone America/New_York [GMT-5:00]
Locale en_US
Java Library Path lib:lib/core/gateway

On the gateway under Configure > OPC-UA > Settings make sure the ‘Endpoint Address’ setting matches the IP of your machine. If you end up having to change it you’ll need to restart the UA module or the gateway to for it to take effect.

Then under OPC Connections > Servers make sure you have a connection that is going to either ‘localhost’ or to the IP from above.

That’s done it.

Is that step in the quick-start?

I think I was thrown by the status saying ok, but the log saying no, and then the Designer tool behavior agreeing with the no.

Thank you for your help!


I’m not sure if it’s in the quickstart or not - it’s not always necessary.

But if you’re on a laptop and your IP is changing you may find your OPC-UA connection is faulted, in which case this is usually a good first step in troubleshooting.

Excellent, and yeah – it’s a laptop.

I set it to “localhost” and that seems to be a suitable substitution. I think it was the VPN – the address in the field was the VPN supplied ip address, and that connection was probably firewalling stuff on the primary port.

I’m good.

Thanks for the quick response – most excellent time-to-resolution there.