Designer color selector issues

Something I do quite often is copy a hex value and paste it into the Hex field on the color chooser.

Unfortunately this feature has been extremely buggy for quite some time. I first noticed it on version 7.5.13 and we have since upgraded to 7.7.5 and the problem still occurs.

Sometimes it works just fine.

Sometimes if I click in the box I can’t paste anything in there or even edit the value. I’ve noticed that sometimes when I’m trying to enter a value the text I’m typing goes into the Angle property field on the Property Editor pane. Usually when the dialog is in this state pressing tab doesn’t move between fields on the dialog like normal but instead selects different properties in the Property Editor pane. Even if those properties are not color fields the color dialog remains open. In this case I have to close the color chooser, select a different component and then go back to the original component and try again. Often that does NOT fix the issue. I haven’t found any process that consistently makes the dialog work correctly.

To further aggravate the issue sometimes the hex field is hidden completely by the Windows task bar. I reported that issue long ago but it has never been addressed. As you can see in the attached screen shot the color dialog is ALWAYS either over or under the task bar unless the property is one that doesn’t allow gradients.

I tried to replicate your first issue, and can’t seem to make pasting into the hex field on the color picker have any problems at all. :scratch: If there’s any way you can make a SSCCE project that consistently has this problem and get it to me, I’d appreciate it.

The second problem should have been fixed in 7.7.3. I tried to recreate it just now, and couldn’t, but I’m also on a Mac. We tried to recreate it in Windows a few months ago (in 7.7.5), and couldn’t recreate it. (Turned out the person who was complaining then was on 7.7.2 and mistyped their version.) I’m flummoxed as to why this is still happening for you in 7.7.5.

Ok, please try this:

[ul]Draw a rectangle on a window.

Click on the pencil icon in the fill paint property and change the fill type to linear gradient.

Click back on the window to close the color dialog.

Click on the rectangle and then on the pencil icon to edit the gradient.

Press the tab button. When I do this I can see different properties being selected in the property editor.

Click back on the window to close the color dialog.

Click on the rectangle and then on the pencil icon to edit the gradient.

Click on one on the gradient stops and try to edit it’s hex value. When I do this I can’t select or edit the value at all.

If this doesn’t produce the same results for you please let me know and I will make a new minimal project to try and demonstrate the problem. BTW I am seeing both issues on both my workstation and also in the test environment which runs Windows Server 28 R2 Enterprise.

Great, that was definitely helpful! I’ll make a ticket for this.

Thank you thank thank you!

And now I may know how to avoid the issue by not using the tab button. I had never made that connection before.

Hello, I am having the same issue in 7.9.7.