Designer Error - java.lang.Exception: Unable to get the view config: View config is undefined

The Ignition Designer does not load my view - instead it give the error

java.lang.Exception: Unable to get the view config: View config is undefined

Hovering over the page view in the project browser shows the preview, which is correct.
Launching a Perspective session and navigating to the view shows the correct view.
Examining the project files in a text editor - they look correct.

Sometimes restarting the designer clears it up.

Sometimes restarting the computer clears it up.

Today neither of those is working.

Any ideas?

What's your Ignition version?

That 'view config is undefined' error is basically the Java part of the designer saying "I tried to ask the web browser frame containing the view for its configuration, and gave up after 30 seconds". So it can be caused by lots of things - problems with the web browser frame, problems with the javascript on the page, problems with the page loading too slowly, etc.

Ignition Platform 8.1.28 (b2023060110)
SFC Module 5.1.28 (b2023060110)
SQL Bridge Module 10.1.28 (b2023060110)
Serial Support Client Module 6.1.28 (b2023060110)
OpcCom Module 6.1.28 (b2023060110)
Perspective Module 2.1.28 (b2023060110)
Reporting Module 6.1.28 (b2023060110)
Symbol Factory Module 7.1.28 (b2023060110)
Alarm Notification Module 6.1.28 (b2023060110)
WebDev Module 5.1.28 (b2023060110)
OPC-UA Module 9.1.28 (b2023060110)
Enterprise Administration Module 4.1.28 (b2023060110)
DNP3 Driver Module 4.1.28 (b2023060110)
Vision Module 11.1.28 (b2023060110)
Web Browser Module 5.1.28 (b2023060110)
  • Connected Gateway:
  • Java Version: Azul Systems, Inc. 11.0.18
  • JVM Memory (used/max MB): 558.0 / 1,024.0

I'm having the same issue today. Recently I'd see this error on a view periodically, and closing all views would allow the view to open. When that didn't work I would save and exit the designer which again would allow the view to open. We are now seeing this on multiple views and closing the views / exiting the designer is not fixing the problem. I haven't tried shutting down the computer running the gateway yet. It's quitting time now, I'll give that a shot tomorrow.