Designer Launch IP Issue

I have 2 clients, each with distinct VPN software and internal gateway IPs, though I’m only ever connected to one VPN at a time.

  • 1st IP: 192.168.0.72:8088
  • 2nd IP: 10.1.1.193:8088

I’ve had no issues with the 1st gateway, but when attempting to launch the Designer from the 2nd client’s gateway, it seems to still want to use the connection information for the 1st.

When using webstart, the login window never opens and no errors are reported.
When launching the designer locally, I get the following Application Error:

com.sun.deploy.net.FailedDownloadException: Unable to load resource: http://192.168.0.72:8088/main/system/launch/designer/designer.jnlp

I’ve tried downloading a native launcher from the 2nd client’s gateway, which actually pulls up the Designer login window. However I am not able to login using verified credentials which leads me to believe it’s still using the wrong IP internally.

In my Java network settings, I’ve tried both “use browser settings” and “direct connection”. Neither option has worked.
In both Gateway’s settings, Web-Launch’s Launch Link Script Policy is set to “Direct”
In my Internet Options, I have not configured any Proxy/VPN settings.

I’ve enabled the Java console and can provide more debug information if needed.
Thanks!

Here’s the contents of my Web-Launch .jnlp file if it helps, note the IP is correct:


<?xml version="1.0" encoding="utf-8"?>
<!-- JNLP file for Ignition client launch -->
<jnlp
  spec="1.0+"
  codebase="http://10.1.1.193:8088/main/"
  href="system/launch/designer/designer.jnlp">
  <information>
    <title>Ignition Designer</title>
    <vendor>Inductive Automation</vendor>
    <icon href="web/platform_logo.png"/>
    <offline-allowed/>
    <shortcut online="true">
      <desktop/>
      <menu/>
    </shortcut>
  </information>
  <security><all-permissions/></security>
  <resources>
    <j2se version="1.8" initial-heap-size="64M" max-heap-size="4096M" java-vm-args="-XX:MaxPermSize=128m"/>
    <j2se version="1.7" initial-heap-size="64M" max-heap-size="4096M" java-vm-args="-XX:MaxPermSize=128m"/>
    <j2se version="1.6" initial-heap-size="64M" max-heap-size="4096M" java-vm-args="-XX:MaxPermSize=128m"/>
    <jar href="system/launchbin/launchclient.jar" download="eager"/>
    <property name="javaws.sr.gateway.addr.0" value="10.1.1.193:8088:8043/main"/>
    <property name="javaws.sr.launchts" value="1516027981281"/>
    <property name="javaws.sr.scope" value="D"/>
    <property name="javaws.sr.main" value="com.inductiveautomation.ignition.designer.DesignerStartupHook"/>
    <property name="javaws.sr.platform.edition" value=""/>
    <property name="sun.java2d.d3d" value="false"/>
    <property name="javaws.sr.memory.init" value="64M"/>
    <property name="javaws.sr.memory.max" value="4096M"/>
  </resources>
  <application-desc main-class="com.inductiveautomation.ignition.client.launch.BootstrapSwing"/>
</jnlp>

Reinstalling the JRE fixed the issue for me.

Would love to know what could have gotten misconfigured/corrupted.