Designer Launcher No Longer Works

Hi there.

Hoping for some help here. A little long winded but hopefully shed some detailed light on my situation.

Problem: Designer launcher no longer opens. What happens is briefly a blank designer window pops up for about 1 second then disappears. I have uninstalled and re-installed to no avail. I have upgraded from Ignition 8.1.5 to 8.1.13 and same problem.
I have followed everything I could find on forum, deleted ignition cache, deleted java cache, updated java. Trying to launch with both AV and firewall disabled. Nothing worked.

Lead up to Problem: I have Maker edition installed on my home computer and was setting up my remote access, DDNS etc and setting up the self signed certificate on the gateway for the interim until I can get a real certificate.
I got all that working from a remote client/browser stand point. (FYI I have two gateways in my designer launch window, one for my home maker edition and one for my work) When I opened designer launcher, my work one was fine but then I tried opening my home gateway and got the “certificate is not trusted” and there were two buttons, Cancel and Trust. I clicked trust and designer launcher just closed. I tried a few times and same thing happened.
I had the “Force Redirect to 8043” set in the gateway and changed it back to default where it does not forced redirect so that 8088 would work locally. Then I started to get the cannot connect to gateway window pop up a bunch of times even though the gateway url was pointing at 8088.
I then decided to uninstall the designer and re-install with a fresh download from the gateway and re-setup my gateway connections for both home and work.
This is when I started getting the problem where the blank designer launcher window just opens briefly and then closes.
BTW this is all happening on my computer which is acting as the ignition server.

I can open and run the designer launcher from a different computer in my home without issue.

Another thing I noticed is that hours before this issue started happening is that the both the client and designer log started logging the incorrect date (year 2022 instead of 2021), exactly 1 year ahead. This seems to coincide approximately with when I changed the IP of the gateway computer from to Ignition gateway/status log time is correct and so is the computer time. This is probably a red herring related to issue but still is very weird.

Dec 27 17:09 is when I first tried launching and connecting and had certificate “Close - Trust” issue above.
Dec 27 17:12 is once I changed the secure redirect in gateway above.
Dec 27 17:16 is when I uninstalled/reinstalled the designer launcher

Here is the designerlauncher.log file.
designerlauncher.log (214.7 KB)

Forgot to mention that I am running Windows 10 Pro 21H2


OK. I think I have solved it.

I copied the all the files in Users/steve/ignition/clientlauncher-data folder from my laptop which works just fine, and pasted it into the same folder on my server/computer which is having the problems. (Moved old files into a temp folder first).

I figured it would most likely be the designer-launcher.json so I compared the new and original files and found that somehow I must have accidentally deleted the “http:\” from one of my gateways addresses when I was changing the :8043 back to :8088 so the address only was without the “http:\”.

Obviously my fault, but to have that cause the launcher to not open is a real PITA. It’s pretty easy to do a typo. And uninstall/reinstall did nothing. Would be nice if the uninstall would delete the json file so previous errors don’t cross contaminate a new install.

The log did not show anything either. Would also be nice if it logged reason for not opening instead of just:
INFO [DesignerLauncher ] [2022/12/28 14:41:34]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2022/12/28 14:41:34]: Updating logging level to INFO

Anyway hopefully this may help someone else. Cheers