Designer Launcher Trust SSL Cert

After I installed a SSL certificate, I was not able to launch the Desinger.
Here is the error I’m getting when selecting the option to trust the SSL cert.

Any ideas on what the problem is from that error?

The Subject Alternative Name extension on your certificate does not contain an entry with that IP address.

Where did you get the certificate?

I got it from GoDaddy.
The IP shown is not the public IP address of the server but the private (accessed over a VPN).
I want the designer to connect to the gateway using the private IP address.

Sorry, that won’t be possible when using a real certificate issued by a public CA. When connecting via HTTPS the certificate must contain an entry for the IP address or hostname you are connecting to. Public CAs will not issue you a certificate containing a reserved/private IP address.

If you leave HTTP enabled (don’t force redirects) you might be able to access the private IP that way, though I’m sure the “Public HTTP Address” settings are probably pointing to the public secured address…

So this setting here:

Force Secure Redirect

When enabled, and if SSL / TLS is enabled, all http traffic will be redirected to its https counterpart.
(Default: disabled)

Yes, that one. I’m not 100% sure this will work though. But you’d make sure that is disabled and then just point your Designer at the private IP and the unsecured port.

That did it but now the domain name is not redirecting to the proper URL.
I may need to adjust my nginx config file to get this to work properly.

Or run a local DNS that has an entry pointing the public name at the 10.* address.

1 Like