Designer launching wrong java version

I’m having trouble getting the designer (and also the client) to launch the correct version of java. I can see I have my gateway set to java 1.8.0_181-b13, but when I launch the designer It wants to launch with java version 1.7.0. I have updated the ignition.conf file, restarting the gateway, and also tried clearing out all of my java cache. I’m not sure what I’m missing. I’m running Ignition version 7.9.9

Webstart is usually pretty aggressive about wanting you to use the latest version. Assuming you’re on Windows, is 8 disabled in the Java control panel?

Yes, I’m on windows 10 64bit. It looks like all versions of java are enabled. I’m sure I can get around this by uninstalling other versions of java, but I want to avoid that path since other applications may use them.
Also, I have been getting the notification from webstart to use the latest version of java (which is 10 in this case), but I know in the past running version 10 has caused problems with script serialization.

I figured out a work around. You have to manually run the .jnlp file with a specific java web start found in the version 1.8 bin folder; however, this isn’t going to work long term if my clients are going to have to launch in the same way.

It isn’t going to work long-term at all, as Java9 and up don’t even have java webstart. The non-Oracle Java8 doesn’t have it anymore, either. You really need to figure out how to standardize on the native client launchers for everything.

You are correct, this would actually be the correct course of action (but it still doesn’t use the version of java specified for the gateway). Interesting though, does the native client use a different pipeline when launching the designer (I’ll admit I don’t know much about how java operates)? I noticed that when I launch the designer from the webstart using Java 10 that it produces serialization errors with regards to gateway scripts; however when launching through the native client and using Java 10 these errors do not occur.