Designer not launching in some machines


recently and without any apparent change Designer for one specific project can not be launched in my laptop. Here are the facts:

  • I can open the designer of other projects (same OS version and same Ignition version, it doesn’t matter).
  • I can open the HMI for this specific project.
  • My colleagues can open the designer of this specific project without problem (and from the same network).
  • I can not open the designer for this specific project.

Things I have tried:

  • deleting all Java temporary files
  • deleting .Ignition folder
  • unistalling/installing Java 8u25 32
  • unistalling/installing Java 8u25 64
  • unistalling/installing Java 7u71 32

None of them worked, while in other machines the designer for this specific project loads without problem and without any specific requirement like Java version or any other.

The Gateway is 7.7.1 x64 on a Windows 2012 Server Standard. My laptop is a Win7 x64. At this moment we are connecting to this project remotely using port forwarding (8088 and 8043) in the remote router.


As a workaround try using Ignition’s native client launchers. It generally works better than Java Web Start.

More information about it here: … uncher.htm


Thanks Nick,

Even with the native web launcher, when I click to launch the designer it desapears and nothing happens. It works fine launching the HMI.


Hi Fran,

Some other things to try:

From the command line. This will uninstall local copies of WebStart apps

javaws.exe -uninstall

Delete your C:\Users[i]username[/i].ignition folder

Another troubleshooting tip when using the native client launcher: open clientlauncher.log and find the line that starts with “Starting Java with the following parameters”. Copy the rest of the line to a terminal window, like so: java -classpath /home/dev/.ignition/clientlauncher-data/launchclient.jar -Dinitial.heap.size=64M -Dmax.heap.size=512M -XX:MaxPermSize=128m -Dsun.java2d.d3d=false com.inductiveautomation.ignition.client.launch.BootstrapSwing

If there is some error being thrown, you should be able to see it in the terminal window as Java is executing.

OK, following the tip from Mr Gross and looking at the error thrown in the terminal window, the problem was related to the amount of memory for the Designer. In the previous days we changed the maximum Memory for the designer (from 512MB to 2GB trying to improve the performance) and looks like this was the root cause for some machines not being able to open the designer.

Now the maximum memory for the Designer is 512MB again and it opens again in machines where it was not opening before.